Clients im WLAN Interface finden sich nicht



  • Hallo!

    Irgendwie steh ich auf der Leitung. Ich habe eine frische pfSense aufgesetzt mit 1x WAN und 1x LAN. Am LAN (192.168.1.0/24) hängt erstmal 1 PC. Dann habe ich via ath_0 ein WLAN Interface (192.168.10.0/24) angelegt. Dort befindet sich ein WLAN Drucker und ein WLAN Laptop.

    Als Regeln steht sowohl im LAN als auch WLAN eine Allow All Rule. Alle Geräte kommen ins Internet. Jedes Gerät kann die pfSense pingen. Der PC kann auch zum Drucker pingen. Der WLAN Laptop kann auch den PC pingen, doch den Drucker nicht. Füge ich ein weiteres Gerät ins WLAN Interface hinzu, findet auch dies den PC, doch nicht den Laptop und Drucker. Sprich alle Geräte im WLAN finden sich untereinander nicht.

    Habe ich irgendwas vergessen?

    Auf beiden Interfaces läuft ein DHCP Server mit Standardeinstellungen. Ansonsten ist auch alles Standard.

    Danke für die Hilfe!



  • Ich habe das Problem nun mit einer Bridge gelöst, dennoch würde es mich interessieren wieso ein reines WLAN Interface das nicht kann?

    EDIT: muss mich korrigieren. Auch mit der Bridge geht es nicht! Ich hatte eben zum Test den Laptop via Kabel am LAN. Er hatte somit die IP 10.0.0.2, ein Handy war via WLAN verbunden und bekam die IP 10.0.0.2. Soweit, so normal. Es funktionierte auch alles. Beide Geräte fanden sich und gingen zu pingen. Nun setze ich den Laptop ins WLAN und er bekommt die IP 10.0.0.4. Nun finden sich Laptop und Handy nicht mehr und können sich auch nicht mehr pingen  :-\

    Warum?!



  • Kann geclosed werden! Im WLAN Interface muss der Haken bei "Allow intra-BSS communication" natürlich gesetzt werden  ;D