HUAWEI E1820 UMTS Stick an pfSense



  • Hallo!

    Ich habe mir den E1820 USB UMTS Stick gekauft und an meine pfSense angeschlossen. Ich habe ihn als PPP Interface hinzugefügt und konfiguriert. Doch schon beim Anschließen kommt folgendes in der Console:

    Nov 26 21:51:50	snmpd[76581]: disk_OS_get_disks: device 'da0' not in device list
    Nov 26 21:51:50	snmpd[76581]: disk_OS_get_disks: device 'cd0' not in device list
    Nov 26 21:51:50	snmpd[76581]: disk_OS_get_disks: device 'da1' not in device list
    Nov 26 21:51:50	snmpd[76581]: disk_OS_get_disks: sysctl_2 kern.disks failed: Cannot allocate memory
    Nov 26 21:51:50	kernel: da1: Attempt to query device size failed: NOT READY, Medium not present
    Nov 26 21:51:50	kernel: da1: 40.000MB/s transfers
    Nov 26 21:51:50	kernel: da1: <huawei tf="" card="" storage=""> Removable Direct Access SCSI-2 device
    Nov 26 21:51:50	kernel: da1 at umass-sim2 bus 2 scbus2 target 0 lun 0
    Nov 26 21:51:50	kernel: ADY, Medium not present
    Nov 26 21:51:50	kernel: cd0: Attempt to query device size failed: NOT RE
    Nov 26 21:51:50	kernel: cd0: 40.000MB/s transfers
    Nov 26 21:51:50	kernel: cd0: <huawei mass="" storage="" 2.31=""> Removable CD-ROM SCSI-2 device
    Nov 26 21:51:50	kernel: us1 target 0 lun 0
    Nov 26 21:51:50	kernel: cd0 at umass-sim1 bus 1 scb
    Nov 26 21:51:50	kernel: (probe1:umass-sim2:2:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
    Nov 26 21:51:50	kernel: (probe1:umass-sim2:2:0:0): SCSI status: Check Condition
    Nov 26 21:51:50	kernel: (probe1:umass-sim2:2:0:0): CAM status: SCSI Status Error
    Nov 26 21:51:50	kernel: (probe1:umass-sim2:2:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
    Nov 26 21:51:49	kernel: (probe0:umass-sim1:1:0:0): SCSI sense: NOT READY asc:3a,0 (Medium not present)
    Nov 26 21:51:49	kernel: (probe0:umass-sim1:1:0:0): SCSI status: Check Condition
    Nov 26 21:51:49	kernel: (probe0:umass-sim1:1:0:0): CAM status: SCSI Status Error
    Nov 26 21:51:49	kernel: (probe0:umass-sim1:1:0:0): TEST UNIT READY. CDB: 0 0 0 0 0 0
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	kernel: umass2: <huawei 0="" 2="" technologies="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr=""> on usbus1
    Nov 26 21:51:48	snmpd[76581]: unknown message from devd socket
    Nov 26 21:51:48	kernel: umass1: <huawei 0="" 2="" technologies="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr=""> on usbus1
    Nov 26 21:51:48	kernel: u3g0: Found 4 ports.
    Nov 26 21:51:48	kernel: u3g0: <huawei 0="" 2="" technologies="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr=""> on usbus1
    Nov 26 21:51:48	kernel: ugen1.2: <huawei technologies=""> at usbus1
    Nov 26 21:51:42	kernel: ugen1.2: <huawei technologies=""> at usbus1 (disconnected)
    Nov 26 21:51:42	kernel: ugen1.2: <huawei technologies=""> at usbus1</huawei></huawei></huawei></huawei></huawei></huawei></huawei></huawei>
    

    Unter Interface Status sehe ich dass er keine IP bezieht und nichts überträgt. Außerdem zeigt er dort:

    Cell Signal (RSSI)	rssi:12 level:-89dBm percent:39%
    Cell Mode	None, No Service Mode
    Cell SIM State	Invalid SIM/locked State
    Cell Service	No Service
    

    Ich denke, dass er nicht richtig als Device erkannt wird, doch wieso?

    Danke!



  • Kann geschlossen werden. Habe den Stick zum Laufen bekommen.

    Der Stick muss als U3G Treiber geladen und als Modem only konfiguriert werden:

    # kldload u3g
    # kldstat
    Id Refs Address            Size     Name
     ...
     7    1 0xffffffff81b6e000 5ffb     u3g.ko
    
    # echo 'u3g_load="YES"' >> /boot/loader.conf
    
    # pkg install usbutils
    # lsusb                                                                                                                  
    Bus /dev/usb Device /dev/ugen3.2: ID 12d1:14ac Huawei Technologies Co., Ltd.
    
    # cat << EOF > /etc/devd/huawei-e1820.conf
    attach 100 {
            device-name "u3g[0-9]+";
            match "vendor" "0x12d1";
            match "product" "0x14ac"; 
            action "/usr/sbin/ppp -ddial saunalahti";
    };
    EOF
    
    # sysctl -a dev.u3g | egrep '\.ttyname'
    dev.u3g.0.ttyname: U0
    
    # cu -s 115200 -l cuaU0.0
    Connected
    AT^U2DIAG=0
    OK
    ~.
    [EOT]
    

Log in to reply