Erro no Redirecionamento de Páginas Bloqueadas pelo SquidGuard (RESOLVIDO)


  • Boa noite, pessoal!

    Eu sou novo no uso dessa poderosa ferramenta, mas já venho acompanhando o fórum há 2 semanas e instalei o PFSENSE 2.1.5 para implantar o firewall no acesso da rede wifi da empresa. Tá funcionando normalmente o Captive Portal, o bloqueio das páginas, entre outros recursos que utilizo.
    Estou usando o Squid 2.7.9 pkg v.4.3.4 e o squidGuard 1.4_4 v1.9.6 e não estou conseguindo configurar o redirecionamento das páginas bloqueadas pelo SquidGuard. Já vi alguns tópicos com o status de resolvido no fórum e realizei as configurações das pessoas que postaram suas soluções e nada. Além de demorar muito para dar o retorno do erro, a página não carrega com a personalização que fiz. Só volta o erro depois de mais ou menos 2 minutos como: ERRO A URL solicitada não pode ser recuperada…Falha na conexão e diz que o sistema retornou (60) Operation timed out. Por favor, alguém poderia me ajudar a solucionar esse problema. Agradeço desde já.


  • Em todas as paginas ou só as HTTPS?


  • Olá Tomas!

    Acontece isso em todas as páginas. E demora muito pra dar o erro.


  • Eu tentaria com Squid3-dev para ver se ocorre o mesmo.
    Uso aqui é está bem estável.


  • Ok Tomas.

    Vou desinstalar o Squid e vou tentar com o squid3-dev. Daqui a pouco eu posto o resultado.


  • Tomas,

    Qual é a versão do SquidGuard que você está usando com o Squid3-dev?
    Instalei a versão squidGuard-squid3 e não inicia o serviço. Já fui lá em Status>Serviços e cliquei para iniciar o serviço e nada. Quando clico no botão para "startar" no Proxy Filter ele não "starta". O que pode ser?


  • Essa versão não roda como serviço, é por demanda.
    Só começar a navegar que o Squid inicia o processo, ele é um processo filho do Squid.

    Pode ver depois que ele vai aparecer como ativo.


  • hummm…ok

    Vou testar então e posto o resultado daqui a pouco.

    Desde já agradeço pelas informações.


  • Tomas,

    Infelizmente não obtive êxito mesmo usando o que vc informou. Anexei o arquivo com a imagem do erro que tá dando na página . Não está direcionando para a página personalizada que criei. Já segui orientações do pessoal do fórum referente ao redirecionamento, mas não obtive sucesso ainda.

    ![erro PFSENSE.png](/public/imported_attachments/1/erro PFSENSE.png)
    ![erro PFSENSE.png_thumb](/public/imported_attachments/1/erro PFSENSE.png_thumb)


  • como esta a configuração do seu squid e squid-guard?


  • Olá Jvicente,

    Fiz a configuração do Squid e do SquidGuard de acordo com as informações obtidas no fórum. Vou tentar detalhar aqui para você entender:
    Mandarei, primeiramente, os "prints" das telas de configuração do squid e logo em seguida mandarei do squidGuard.









  • Segue as imagens com as configurações do SquidGuard…









  • Faltou uma…



  • squid-guard?

    tem o codigo ai da pagina de erro que vc customizou?


  • estou mandando anexo um exemplo do arquivo sgerror.php é só procurar o conteúdo HTML dentro do php e customiza-lo a vontade.

    Acesse a pasta /usr/local/www e faça uma copia do arquivo sgerror.php antes e vc pode edita-lo pelo proprio webgui ou transferi-lo atraves de alguma ferramenta como por exemplo o winscp na estrutura que mencionei .

    sgerror.php.txt


  • Olá Jvicente,

    Desculpa a demora. Vi o seu post e vou fazer os testes com esse código. Postarei em anexo o código do erro customizado que criei para você analisar.

    erroses.txt


  • Jvicente,

    Infelizmente não deu certo. Colei a logo dentro do diretório /usr/local/www e mesmo assim não aparece a imagem de erro criada. Sem contar com a demora pra dar o erro da página bloqueada. Vou anexar o erro que o squid retorna. E outra: Já venho há duas semanas quebrando a cabeça com a configuração do PFSENSE 2.1.5. e noto que quando instalo o squidGuard-squid3 meu servidor trava direto dando uma mensagem de swap_pager_getswapspace(16)… Já não sei mais o que fazer. Como está o seu servidor? Tá rodando tudo tranquilo? Por favor, informa pra mim como você configurou o seu firewall. Tô pensando em formatar meu servidor novamente. Será a terceira vez.

    ![erro errado.png](/public/imported_attachments/1/erro errado.png)
    ![erro errado.png_thumb](/public/imported_attachments/1/erro errado.png_thumb)


  • lendo novamente seu post que vi que vc esta utilizando o captive portal, infelizmente nunca utilizei ele, mas a tarde se tiver um tempo eu tento montar um ambiente para testar aqui.
    Vc se baseou a partir de onde para configurar o seu ambiente?

    Qual o tipo de autenticação vc esta utilizando radius ou voucher ou nenhuma?


  • Cara eu vi a mensagem de erro seu e o código esta como time out. Seu squid esta configurado com transparente sem filtro ssl?


  • Olá Jvicente,

    Estou utilizando a autenticação do Captive Portal sem a utilização de voucher. Só a autenticação com o usuário e a senha. Aguardo um retorno seu. Agradeço desde já pela atenção.


  • Olá Marcosmoya18,

    O squid está configurado sim como transparente sem filtro ssl. Isso interfere em algo?


  • Olá pessoal!

    Instalei o PFSENSE 2.1.5 em outra máquina mais robusta e refiz toda configuração do zero SEM restaurar meu backup da máquina que tava apresentando o problema.
    Instalei o Squid3-dev com squidguard-squid3 e funcionou legal o redirecionamento da página de erro utilizando o código do post do amigo jvicente. Configurei o captive portal autenticando usuário e senha na base local mesmo, deixei o proxy transparente e o squidguard bloqueando a blacklist do site shallablacklist. Só tenho a agradecer pela atenção de todos.
    Muito obrigado!


  • Como esta suas regras de firewall? Você esta bloqueando sites https?


  • Olá marcomoya!

    Não estou bloqueando sites https não. O bloqueio é em cima somente de sites pornográficos.


  • mano eu tive o mesmo problema que você… refaça o dd da blacklist ou então baixe ele de novo.