[SOLUCIONADO]Duda en configuración WAN con datos de proveedor



  • Buenas, no estoy muy seguro de como configurar la interfaz WAN para el proveedor wimax al que voy a sustituir su router, un mikrotik, por un pfsense que estoy instalando. Los datos del proveedor son los siguientes:


    IP: 172.16.10.205
    Mask: 255.255.255.0
    Gateway: 172.16.10.1

    Lookback: 87.87.87.87/32
    Src.Addr: 87.87.87.87

    Nota asegurar que la ruta por defecto se identifica con la 87.87.87.87
    —–---------------------------
    La ip pública sería la 87.87.87.87 (nótese que la he cambiado con respecto a la que es por privacidad)

    ¿Dónde tendría que configurar esa ip loopback para su correcto funcionamiento en pfsense?
    Si además de decirme donde se configura me explica brevemente porque eso es así lo agradecería un montón!

    Muchas gracias de antemano! Saludos!



  • La verdad no entendí mucho..  pero como es eso de configurar la loopback con esa ip? La wan en pfsense la configuras como una interfaz cualquiera. En este caso static



  • Usualmente se utilizar 127.0.0.1 para direcciones de loopback.

    Pero para el caso de que requieras direcciones loopback y estes corriendo OSPF o BGP para que la interface siempre este arriba y no tengas cambios en la metrica de las rutas si es posible qe puedas utilizar alguna otra direccion.

    La verdad es que no tengo mucha idea de como crearla en pfsense. tal vez con una virtual address



  • Probablemente el proveedor  es el que use  OSPF o BGP para que la interface siempre este arriba e imagino que también para ahorrar ips públicas, pero me complica un poco la configuración con esos datos que me ha dado. Yo también he pensado en una virtual address, pero no estoy nada seguro de como hacerlo.

    Pero me han insistido en que eso debe ir así. No creo que se refieran a la ip loopback local, de ahí mi pregunta. Y el caso de que lo sea como cambiarla.

    Muchas gracias por las respuestas por ahora, a ver si conseguimos dar con la clave, ya que el operador se desentiende si quitamos su router y esos son los datos de configuración que me ha dado,



  • El proveedor te ha mencionado que tiene corriendo OSPF ?



  • No me lo ha mencionado, debería preguntarselo? Todavía estoy funcionando su router mikrotik, iré haciando pruebas de todas formas. Pero me gustaría saber si alguien, aunque sea intuitivamente o tiene una noción de como debo configurar eso, toda ayuda es agradecida.  :)

    Saludos! Cuando vaya al lío contaré lo que me vaya surgiendo, y cuando me pueda poner en contacto con ellos intentaré sacarle algo más de información.

    Gracias!



  • Tienes accceso al router mkt ?

    Si tu proveedo esta ejecutando OSPF , deberas de instalar el paquete de OSPF en tu PFSENSe y hacer la configuracion adecuada, ya que el solo hecho de configurar la interface loopback no resolvera el problema.

    Saludos



  • Cuando un proveedor de servicio no me da información, lo lógico sería cambiarlo, tú eres el cliente… además que me levanta las alertas de seguridad cuando hay algo "oscuro". Por otro lado, podrías colocar tu pfSense igualmente y dejar el router del proveedor como un router de la nube y no te complicas...  :)

    Saludos



  • **En temas poco habituales mejor aclarar siglas, para que todos puedan entender de qué se trata:

    OSPF –-> http://es.wikipedia.org/wiki/Open_Shortest_Path_First

    BGP ---> http://es.wikipedia.org/wiki/Border_Gateway_Protocol

    ¡Gracias!

    Moderador**



  • Dejar el router del proveedor sería una opción sino fuera porque quiere cobrar 700€ por un router Mikrotik RB/2011L-RM que en el mercado no llega a los 90€. Y si no se lo compro no me deja tener acceso a el y ver la configuración que tiene.

    La situación es que en no tengo alternativa de ISP y necesitamos el ancho de banda que en la zona por wimax es el único que lo oferta. A lo largo de esta semana que entra comenzaré las pruebas y las llamadas al proveedor, a ver con que sale… Porque es un proveedor local y si, andan con mucho oscurismo, pero de verdad, la otra alternativa es la que teníamos hasta ahora, contratar unas 20 ADSL que no llegan ni a los 6mb por la distancia que estamos de la central....

    Sigo insistiendo que cualquiera que pueda aportar lo más mínimo a resolver mi duda lo agradecería, ya que todavía no se por donde entablar la ip loopback esta...

    He buscado ejemplos de configuración OSPF pero no me quedan claras, alguien me recomienda leer algún post, tutorial, documentación?

    Muchas gracias nuevamente.

    Saludos.

    Por cierto, por si alguien le surge la duda, es la Red de un colegio en la que estoy echando una mano con la Red desinteresadamente  ;)



  • @Zim_Zum:

    Contratar unas 20 ADSL

    No te lo recomiendo. Complicado hacer un agrupamiento de puertas (balanceo saliente) con 20 equipos. Tendrías que meter un switch gestionable entre pfSense y los enrutadores para poder manejar VLANs. Físicamente no caben tantas tarjetas de red en un equipo (aunque fuesen de bocas múltiples) y por lo que leí algún día las BIOS suelen tener un número máximo de NIC (tarjetas de red) gestionables.

    quiere cobrar 700€ por un router Mikrotik RB/2011L-RM que en el mercado no llega a los 90€.

    Bueno, una cosa es lo que valen los equipos y otra lo que valen las soluciones. Parece que tu proveedor no sabe vender bien "la solución".



  • @Zim_Zum:

    Buenas, no estoy muy seguro de como configurar la interfaz WAN para el proveedor wimax al que voy a sustituir su router, un mikrotik, por un pfsense que estoy instalando. Los datos del proveedor son los siguientes:


    IP: 172.16.10.205
    Mask: 255.255.255.0
    Gateway: 172.16.10.1

    Lookback: 87.87.87.87/32
    Src.Addr: 87.87.87.87

    Nota asegurar que la ruta por defecto se identifica con la 87.87.87.87
    —–---------------------------
    La ip pública sería la 87.87.87.87 (nótese que la he cambiado con respecto a la que es por privacidad)

    ¿Dónde tendría que configurar esa ip loopback para su correcto funcionamiento en pfsense?
    Si además de decirme donde se configura me explica brevemente porque eso es así lo agradecería un montón!

    Muchas gracias de antemano! Saludos!

    Por lo que dices el tema se reduce a:

    • Configurar WAN como te dicen.

    • Desmarcar Block Private Networks en la interfase WAN

    • Ponerle a WAN como IP virtual la IP pública que te dan

    https://doc.pfsense.org/index.php/What_are_Virtual_IP_Addresses



  • Ya probaste en configurar la misma dirección IP que te da el proveedor? porque en tus post de configuración no usas la misma que te da el DHCP., ya te digo que es posible que internamente el proveedor permita el NAT solo a las IPs que entrega y no a todo el pool.

    Saludos.



  • Exactamente como ha dicho Bellera se reduce a lo más simple:

    • Configurar WAN como te dicen.

    • Desmarcar Block Private Networks en la interfase WAN

    • Ponerle a WAN como IP virtual la IP pública que te dan

    De este modo desde el exterior puedo hacerme ping a la ip pública, puedo acceder incluso al portal de pfsense permitiendo que se haga desdel WAN. Pero no me funciona en las diferentes redes que tengo. (las pongo en las capturas de más adelante, estoy usando VLAN)

    https://www.dropbox.com/s/98w4dpinzurnsgm/pfscsa1.PNG
    https://www.dropbox.com/s/8sr4xd9buqengtx/pfscsa2.PNG

    La cosa es que usando su router en mi WAN funciona perfectamente, el problema es cuando aplico su configuración, repito, desde internet puedo acceder a mi PFsense, lo veo, el problema esta en que no se está haciendo NAT desde las "LAN".

    ¿Que problema puede haber? ¿Hay que hacer algún cambio en el NAT cuando se usan Virtual IP? He podido leer que es compatible con NAT, pero tal vez hay que hacer otra cosa.

    He probado a crear una gateway con la ip publica para la interfaz WAN, pero funciona igual que con la 172.16.10.1, imagino que por realmente al ser una Virtual IP realmente estoy poniendo lo mismo…

    Todavía no se donde esta el fallo, pero por lo menos verme desde internet aunque sea para entrar en pfsense, ya me tranquiliza, ya se que el problema está en mi configuración de pfsense. ¿Alguna idea?


  • Rebel Alliance

    Si no estoy errado, tienes que configurar "Manualmente" el NAT para que utilice la VIP. ;)



  • @ptt:

    Si no estoy errado, tienes que configurar "Manualmente" el NAT para que utilice la VIP. ;)

    Me podrías guíar un poco como hacer esto? Es que no estoy seguro, ya te digo que ayer estube indagando de hacer eso, pero no encontré como, de todas formas seguiré buscando en la documentación…

    Muchas gracias!


  • Rebel Alliance

    Van unas capturas de pantalla:

    Primero cambias de NAT Automático a Manual

    Luego, si quieres que TODO el trafico salga NATeado por la IP Virtual, puedes ir editando la Reglas que te crea el pfSense de manera automática, y cambias "Interface address" por la "Ip Virtual"

    Listo…

    Si te equivocas, o no funciona, simplemente borras todas la reglas de NAT, cambias a "Auto" aplicas, y vuelves a cambiar a "Manual" y comienzas de nuevo ;)










  • Edito el título con [SOLUCIONADO], efectivamente ptt, de ese modo he conseguido que funcionen todas las interfaces con NAT.

    Muchas gracias a todos por la ayuda ofrecida :D


Log in to reply