Steam Dedicated Servers not showing up in server lists



  • pfsense v2.1

    I read and followed the sticky on outbount NAT.

    I've tried forwarding a number of ports suggested in other posts; 4379, 3478, 4380, 27015, and my 2x ports my games are running; 27016 and 28016.

    Other hosted games work fine, but steam games - players can connect, but the servers (Space Engineers, and Rust) don't show up in server lists for me (they may show up for others?)  >:(

    For the outbound NAT I set mode to 'Advanced Outbound NAT', and copied the mapping for my subnet:
    Interface: WAN
    Source: 192.168.1.0/24
    Source Port: 27016
    Destination: *
    Destination Port: *
    NAT Address: WAN address
    NAT Port: *
    Static: yes

    And I moved that up above the mapping I copied.

    Still nothing, any help would be greatly appreciated!



  • update

    I plugged in my old basic router, and simply by forwarding 1 port (27016) my game came up, I could see it in my server list, I could connect to it.  And when I used an online port scan I could see it active.

    With pfSense I don't see anything.  I have that port forwarded.  I have tried all the NAT replection options.  I have created an outbound rule with the source network (my LAN), and destination port of 27016. (matching the default port 500 rule) and made sure it was 'Static port'.  put this rule above the other default rule.

    Still nothing.  I can't get an online port scanner to see 27016 open/active.  I can't connect to the server's via wan port, or see it in any list.

    (this is a Steam Server - Space Explorer's and I run Counter Strike GO also, same thing.  other game servers like MineCraft forward fine.)

    Thanks in advance for any help!?



  • Did you add the complimentary firewall rule that allows that port-forwarded traffic on 27106 to actually enter from WAN?



  • Thanks.  Yes. I verfied that it automatically creates a firewall rule (and that looks correct) for every port in the port forward list…they are 'linked'.

    The ports for my other servers (minecraft and such) are working perfectly.  All 'Steam' servers won't work.  It's something specific to steam servers (counterstrike, space engineers, rust, etc).

    There is a post about why it is broken in pfSense (it works differntly then my old basic router) and requires 'Outbound' NAT rules.  I think this is where I'm making a mistake.



  • I admit that I know nothing about this issue, but the first thing I would do is start sniffing the traffic when things aren't working and then start looking for blocked traffic from their IP space.  There's likely more to it than hat if it's a general problem with 2.1.x and Steam.

    You might also want to try a 2.2-BETA snapshot and see if the problem persists.



  • thanks for the advice.  I'm currently running 2.2 beta.

    How would I start 'sniffing' around?  Is there an option for this or should I look at a specific log?



  • pfSense comes with a packet sniffer.  I don't have it in front of me right now, but I think it's under Diagnostics - Packet Capture.  Select your interface, do your thing to make it fail and then use Wireshark to follow the flow and see if you can see the problem.

    I assume you've already used the Firewall log to check for blocked traffic from their IP space?


Log in to reply