PfSense + SIP + wechselnde WAN-IP



  • Hallo,

    ich hatte vor wenigen Monaten noch pfSense als Firewall im Einsatz und musste diese leider vorübergehend ersetzen, da es Probleme mit den SIP-Devices gab. Wir haben hier mehrere IP-Telefone (snom, Panasonic) welche mit sipgate verbunden werden. Seit der Umstellung auf reine IP-Telefonie bestand damals das Problem, dass nach einiger Zeit die Telefone nicht mehr funktionierten (weder eintreffende noch ausgehende Telefonate). Nach einer Recherche konnte ich das Problem lokalisieren:

    1. WAN-IP Adresse wechselt (meist Nachts) durch den automatischen oder herbeigeführten DSL-Reconnect.
    2. Da die SIP-Devices alle x Sekunden Pakete aussenden, werden die vorhandenen States in der Firewall nicht entfernt und enthalten somit weiterhin die alte IP!
    3. Resultat: Die Telefone sind am nächsten Morgen "tot", da die Verbindung zu sipgate nicht mehr funktioniert.

    Damals gab es keine geeignete Möglichkeit um die States nach einem Reconnect zu entfernen oder einen Expire-Wert pro Gerät festzulegen. Mittlerweile hat sich auch bei pfSense wohl wieder einiges getan, daher möchte ich an dieser Stelle kurz anfragen ob jemand ähnliche Probleme hatte und wie diese gelöst wurden - oder ob pfSense sogar intern neue Möglichkeiten hierfür bietet

    Noch als Zusatzhinweis: Mit anderen Routern funktionieren die SIP-Devices bis heute einwandfrei, ohne besondere Einstellungen - z.B. mit einer FritzBox. Man könnte nun zwar die pfSense hinter dem Router anschliessen und die SIP-Devices parallel dazu, allerdings wäre mir der direkte Betrieb mit pfSense + DSL-Modem lieber.

    Grüsse,

    Michael



  • Schau mal bei

    System: Advanced: Miscellaneous

    ->State Killing on Gateway Failure

    Hoffe das hilft!



  • Danke für die schnelle Rückantwort! Unter dem genannten Menü ist die Checkbox für "State Killing on Gateway Failure" derzeit aktiviert. Ist dies die Standardeinstellung bei pfSense? Soweit ich dem Erläuterungstext hierzu entnehmen kann, muss diese Checkbox deaktiviert sein damit die States gelöscht werden, sobald ein Gateway (in meinem Fall dann der WAN-Port für DSL) down ist, richtig?



  • Nach nunmehr 14 Tagen nochmals eine Rückmeldung meinerseits und ein grosses Dankeschön - die VOIP-Telefone funktionieren nun einwandfrei, seitdem die "State-Killing"-Einstellung angepasst wurde! :)


Log in to reply