Slow GUI aginst m0n0wall



  • same hardware
    why so slow on pfsense gui, on m0n0wall is so quick?



  • Why not ask why a apple tastes different than a pear?

    You really need to supply more information.  What page?  What version of m0n0wall?  What version of pfSense?  Would be some nice starter information.



  • pfsense 1.2 (24.feb.08)
    mono 1.3b10
    same story on pfsense 1.2rc4, rc3, and mono 1.3b9, b8,..

    same hardware(wrap),
    any page(example fw rules) on mono <1sec
    any page(example fw rules too) at least 2sec
    clean install on both, mono and pf
    same store on firefox(pc and mac) and IE7(pc)

    @sullrich:

    Why not ask why a apple tastes different than a pear?

    You really need to supply more information.  What page?  What version of m0n0wall?  What version of pfSense?  Would be some nice starter information.



  • Please add some more specs about your hardware. pfSense CAN run on embedded systems for example whereas m0n0 was DESIGNED for embedded systems. They have a different memory footprint, different features, m0n0 runs completely from ran once it's up, pfSense runs from a mounted filesystem, they use different webservers for the webgui,  etc.



  • @hoba:

    Please add some more specs about your hardware.

    @gi7:

    system: wrap with 266Mhz



  • Oops, overread that. Thanks jahonix. I have seen some slowlyness especially on such systems too. There is a cache setting that can be tuned (see http://cvstrac.pfsense.org/chngview?cn=16988 ). You can play around with that value by editing the file at diagnostics>edit file. After changing the cache-size please reboot and retest the webgui. Maybe install fasterfox as it has a pageloadtimer to measure the differences. In the past this value made a big difference in performance. The interesting thing is that if set this to a too high value the performance is going down again, so the bigger the better doesn't work here (besides that you only have 128 mb RAM on a wrap anyway). If you find much better performance with a different setting please let us know.



  • I am running v1.2 as well, on a system with 512mb ram, a 2.6 northwood celeron, and a 40gig WD hd. The gui does seem pretty slow, haven't firgured it out myself. Other than that it's a dream come true.


Locked