Link-mtu and tun-mtu warning logged every hour



  • My vpn connection is working but I get the following log messages every hour. How to fix?

    openvpn[56484]: WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1542', remote='link-mtu 1574'
    openvpn[56484]: WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'



  • What sort of OpenVPN is it? Is this a client from pfSense up to an internet-VPN service, or a server on pfSense providing road-warrior access, or site-to-site between 2 pfSense, or?

    Do you have anything in the Advanced box of your OpenVPN settings?

    The other end is looking for (hoping for?) a larger maximum transmission unit (MTU) on the link. First it is best to understand why, because your "local" settings there seem more usual to me.

    Once you understand why the higher numbers are needed/preferred you could put in the Advanced box:

    link-mtu 1574;tun-mtu 1532;
    

    to force your end to match the remote.



  • It is a client from pfSense up to an internet-VPN service.

    Advanced box:
    remote-random
    auth-user-pass
    persist-key
    persist-tun
    tls-client
    comp-lzo
    verb 1

    I have added link-mtu 1574;tun-mtu 1532; and restarted but I see the following in the log:

    openvpn[4644]: /usr/local/sbin/ovpn-linkup ovpnc2 1500 1542 10.12.0.22 10.12.0.21 init

    Thank you for your help


Log in to reply