Ancora NAT



  • Buon giorno a tutti.
    Sto seguendo un problema da un cliente e non riesco ad uscirne.
    Su due Esxi ho installato pfsense che sono collegati tra di loro da un tunnel site-to-site OpenVpn. A valle del pfsense 2 client (OpenVpn) c'è un server 2 che espone un servizio sulla porta 8080.
    Poi ci sono i client che si collegano direttamente al server se sono in locale (pfsense 2 lato client).
    Se i client sono fuori sede, si collegano via OpenVpn road-warrior al pfsense 1 che fa da sever e poi accedono al sever 2 dall'altro lato del tunnel.
    Fino a qui funziona tutto.
    Ora il cliente ( gran rompiscatole tanto per cambiare) vuole che un utente possa accedere al server 2 che espone il servizio sulla porta 8080 tramite il pfsense 1 server, ovvero sull esxi 1 oltre pfsense c'è un server 1 che risponde ad un ip pubblico, io ho creato una regola nat sul pfsense che qualora questo ip riceve una chiamata sulla porta 2345 la gira all'ip del server 2 che sta dietro al tunnel girandolo sulla porta 8080.
    Se inoltro questa interrogazione dal  server 1 sull'esxi 1 il server risponde regolarmente il nat funziona.
    Se inoltro questa interrogazione da internet, il browser va in time out, e sul pfsense client un trace con tcpdump, mi dice che a fronte della richiesta inoltrata tramite pfsense 1 (server ) tramite tunnel, la risposta non torna indietro tramite il tunnel ma viene indirizzata direttamente all' ip internet che ha fatto la richiesta esterno.
    Sul pfsense 2 non ho creato nessuna regola per questo nat.
    C'è qualcuno che ha idea di dove sto sbagliando??
    Grazie



  • Ciao,
    forse uno schema aiuterebbe a capire com'è strutturta la rete perchè così è veramente difficile.
    Però ad occhio  ti direi che il problema è legato ai gateway.

    Ciao Fabio


Log in to reply