Installation on a watchguard x750e with 80Gb HDD


  • Netgate Administrator

    I'll start by saying that flashing the bios is inherently risky etc…..  ;) So you may choose to just stick with what you're running.
    As well as booting far more things the B8 BIOS has a working (to some extent) ACPI table so you get the CPU temperature on the dashboard.

    The B8 BIOS is not shown in the docs because it was an experiment at first. Many people have installed it now though with no issues reported.
    If you're running 2.1.5 you can flash the bios using flashrom from within pfSense. This got more complex in 2.2 because the ngpkg system is far less co-operative! You can use the FreeDOS image on a CF card and flash it from there exactly as you did the B7 bios. If you use flashrom you may have to reset the CMOS afterwards using the jumper as I don't think it can be done from the command line like you can with awdflash.

    Steve



  • Yes I know, bios flashing is always risky…

    About the ACPI table, i'm also getting the temperature read out with the B7 bios.
    Or are these not the right values ?

    ![Status_ Dashboard.jpg](/public/imported_attachments/1/Status_ Dashboard.jpg)
    ![Status_ Dashboard.jpg_thumb](/public/imported_attachments/1/Status_ Dashboard.jpg_thumb)


  • Netgate Administrator

    That looks about right for the original Celeron CPU. Odd I've never managed to enable ACPI in the earlier BIOS versions without bad things happening. Thinking about it though I may never have tried it with the original CPU.
    Do you have 'None/ACPI'  selected for the thermal sensor in System: Advanced: Miscellaneous:?

    Steve



  • @stephenw10:

    Do you have 'None/ACPI'  selected for the thermal sensor in System: Advanced: Miscellaneous:?

    Steve

    Yes i have none/acpi in pfSense



  • I was searching if there is a script or program, that makes it possible to reboot the firewall with the front buttons.
    Probably making use of LCDproc.

    Or restart the webgui and some other cool stuff  :)

    If someone has experience with the LCDproc package and can point me in the right direction, would be great !  8)


  • Netgate Administrator

    Ceama posted a script that does things like a while ago in the x550e thread. It uses the lcdexec command.

    https://forum.pfsense.org/index.php?topic=20095.msg291392#msg291392

    I've never tried it myself. It might require some modifying.

    Steve



  • nice, thx !!



  • After upgrading to 2.2 I get this message when booting…

    cpu0 on motherboard
    est0: <enhanced speedstep="" frequency="" control="">on cpu0
    est: CPU supports Enhanced Speedstep, but is not recognized.
    est: cpu_vendor GenuineIntel, msr 6120f2906000f29
    device_attach: est0 attach returned 6
    p4tcc0: <cpu frequency="" thermal="" control="">on cpu0
    pmtimer0 on isa0

    Fatal trap 12: page fault while in kernel mode
    cpuid = 0; apic id = 00
    fault virtual address  = 0x0
    fault code              = supervisor read, page not present
    instruction pointer    = 0x20:0xc0da8cf0
    stack pointer          = 0x28:0xc2420c28
    frame pointer          = 0x28:0xc2420c34
    code segment            = base 0x0, limit 0xfffff, type 0x1b
                            = DPL 0, pres 1, def32 1, gran 1
    processor eflags        = interrupt enabled, resume, IOPL = 0
    current process        = 0 (swapper)
    [ thread pid 0 tid 100000 ]
    Stopped at      strncmp+0x20:  movzbl  0(%esi),%ebx

    Anybody got a clue where to start ?</cpu></enhanced>



  • nervermind… got it.

    set vfs.root.mountfrom=ufs:/dev/ad0s1a
    (because I changed my HD from slave to master)

    set hw.ata.ata_dma="1"
    (because I flashed the V8 bios)

    @ Stephen
    I also put in a SL7SM, this thing flies like crazy now  :)


  • Netgate Administrator

    Hmm, interesting that that worked. That loader varible has been deprecated as far as I'm aware. The 2.2 Nano images are set to use DMA by default and you have to disable it if that's what you need. See:
    https://doc.pfsense.org/index.php/UpgradeGuide#Disk_Driver_Changes

    Those old Pentium-M CPUs are so cheap now, great upgrade.  :)

    Steve



  • yes i read that and also tried it, but no dice…
    I kept getting the error.

    thx for the link on LCDproc problem.
    Got it working again  :)

    snort also needed some softlinks in order to get it up and running again.

    I searched through my heap of laptops i got lying around, and found the SL7SM  :)


  • Netgate Administrator

    Free is the best sort of upgrade.  ;D



  • yep  ;D



  • Hi TieT,

    Add the following to your /boot/loader.conf.local file.

    hint.ata.0.dev0.mode=PIO4
    

    Remove the line that reads:

    hw.ata.ata_dma="0"
    

    You will then find your disks configured thus (see dmesg) which shows PIO on the CF (ada0) and DMA on the HDD (ada1).

    ada0 at ata0 bus 0 scbus0 target 0 lun 0
    ada0: <sandisk sdcfh-004g="" hdx="" 6.02="">CFA-0 device
    ada0: Serial Number ABZ042211193008
    ada0: 16.700MB/s transfers (PIO4, PIO 512bytes)
    ada0: 3815MB (7813120 512 byte sectors: 16H 63S/T 7751C)
    ada0: Previously was known as ad0
    ada1 at ata0 bus 0 scbus0 target 1 lun 0
    ada1: <st9402115a 3.01="">ATA-6 device
    ada1: Serial Number 5PV09ZED
    ada1: 100.000MB/s transfers (UDMA5, PIO 8192bytes)
    ada1: 38154MB (78140160 512 byte sectors: 16H 63S/T 16383C)
    ada1: Previously was known as ad1</st9402115a></sandisk> 
    

    I'm now getting the performance I need for my disk used for logs and caching under 2.2.

    $ diskinfo -tv /dev/ad1
    /dev/ad1
            512             # sectorsize
            40007761920     # mediasize in bytes (37G)
            78140160        # mediasize in sectors
            0               # stripesize
            0               # stripeoffset
            77520           # Cylinders according to firmware.
            16              # Heads according to firmware.
            63              # Sectors according to firmware.
            5PV09ZED        # Disk ident.
    
    Seek times:
            Full stroke:      250 iter in   7.926598 sec =   31.706 msec
            Half stroke:      250 iter in   6.203416 sec =   24.814 msec
            Quarter stroke:   500 iter in   9.877891 sec =   19.756 msec
            Short forward:    400 iter in   3.476113 sec =    8.690 msec
            Short backward:   400 iter in   2.381591 sec =    5.954 msec
            Seq outer:       2048 iter in   0.197696 sec =    0.097 msec
            Seq inner:       2048 iter in   0.179296 sec =    0.088 msec
    Transfer rates:
            outside:       102400 kbytes in   3.135350 sec =    32660 kbytes/sec
            middle:        102400 kbytes in   3.745807 sec =    27337 kbytes/sec
            inside:        102400 kbytes in   5.382397 sec =    19025 kbytes/sec
    
    

    Steve


  • Netgate Administrator

    Tie isn't booting from the CF card so it may not be necessary to disable DMA at all.



  • I see he's updated his BIOS. Missed that.

    Steve


  • Netgate Administrator

    Yeah, seems slightly odd that he needed to do anything.  :-\



  • I get these numbers:

    [2.2-RELEASE][admin@fw1.home]/root: diskinfo -tv ad0
    ad0
            512             # sectorsize
            80026361856     # mediasize in bytes (75G)
            156301488       # mediasize in sectors
            0               # stripesize
            0               # stripeoffset
            155061          # Cylinders according to firmware.
            16              # Heads according to firmware.
            63              # Sectors according to firmware.
            WD-WXEX08TJ6328 # Disk ident.
    
    Seek times:
            Full stroke:      250 iter in  11.428668 sec =   45.715 msec
            Half stroke:      250 iter in   7.231832 sec =   28.927 msec
            Quarter stroke:   500 iter in  15.496462 sec =   30.993 msec
            Short forward:    400 iter in   5.091478 sec =   12.729 msec
            Short backward:   400 iter in   4.274550 sec =   10.686 msec
            Seq outer:       2048 iter in   0.328848 sec =    0.161 msec
            Seq inner:       2048 iter in   0.309770 sec =    0.151 msec
    Transfer rates:
            outside:       102400 kbytes in   3.423876 sec =    29908 kbytes/sec
            middle:        102400 kbytes in   4.502569 sec =    22743 kbytes/sec
            inside:        102400 kbytes in   4.267557 sec =    23995 kbytes/sec
    

    But I will test it again today and post back the results, maybe i overlooked something.



  • You guys where right, the line doesn't do anything and my system booted perfect when i removed it.

    hw.ata.ata_dma="1"
    

    I think it was a layer 8 problem… trying to do too much at the same time  :)

    these are my results now

    
    ata0: DMA limited to UDMA33, controller found non-ATA66 cable
    ada0 at ata0 bus 0 scbus0 target 0 lun 0
    ada0: <wdc wd800beve-00uyt0="" 01.04a01="">ATA-7 device
    ada0: Serial Number WD-WXEX08TJ6328
    ada0: 33.300MB/s transfers (UDMA2, PIO 8192bytes)
    ada0: 76319MB (156301488 512 byte sectors: 16H 63S/T 16383C)
    ada0: Previously was known as ad0</wdc> 
    
    [2.2-RELEASE][admin@fw1.home]/root: diskinfo -tv ad0
    ad0
            512             # sectorsize
            80026361856     # mediasize in bytes (75G)
            156301488       # mediasize in sectors
            0               # stripesize
            0               # stripeoffset
            155061          # Cylinders according to firmware.
            16              # Heads according to firmware.
            63              # Sectors according to firmware.
            WD-WXEX08TJ6328 # Disk ident.
    
    Seek times:
            Full stroke:      250 iter in  10.765901 sec =   43.064 msec
            Half stroke:      250 iter in   8.400064 sec =   33.600 msec
            Quarter stroke:   500 iter in  15.856698 sec =   31.713 msec
            Short forward:    400 iter in   5.024369 sec =   12.561 msec
            Short backward:   400 iter in   5.086160 sec =   12.715 msec
            Seq outer:       2048 iter in   0.319964 sec =    0.156 msec
            Seq inner:       2048 iter in   0.329491 sec =    0.161 msec
    Transfer rates:
            outside:       102400 kbytes in   3.433698 sec =    29822 kbytes/sec
            middle:        102400 kbytes in   3.800647 sec =    26943 kbytes/sec
            inside:        102400 kbytes in   4.714269 sec =    21721 kbytes/sec
    
    

    Conclusion: need a faster disk  ;D


  • Netgate Administrator

    Thanks for testing that. I was pretty sure but it's nice to know for certain.  :)

    Steve


Log in to reply