OPNsense dead



  • Hi!

    I had a OPNsense running for half a year without any problems.

    Yesterday I had a power breakdown for 5 minutes and my pfsense died. With dying I mean it doesn't do anything. I got that by not receiving IPs for the running computers. I tried plugging it off and on, connecting my MacBook directly to the PFsense but nothing.
    Today I got a null modem cable for directly getting the output but all I get is some letters as you can see in the picture.

    My question is now: Is the PFsense broken or is something wrong with the connection of the null modem cable.



  • Can't see your screenshot!
    For a serial console, try various speeds 9600, 38400, 115200 bps. Garbled characters usually just means the speed is not set right.



  • Sorry, screenshot is visible now.

    Thanks for your reply. I will try another speed and also another driver of the USB-adapter when I am home again.

    I actually thought that the speed is fixed by the PFsense and is always 9600?



  • With 2.1.* the speed is usually 9600 but it can be changed. The BIOS of your system might output at a different speed, so if the BIOS is trying to tell you something first then you would need a different speed to see that.
    Try a whole list like 2400,4800,9600,19200,38400,115200 and hopefully you will get some joy and then be able to see what real problem the system has.


  • Netgate Administrator

    Indeed. OPNSense made quite a few boxes. If it's the smaller 3-port ALIX based box I believe the default bios rate is 38,400.

    Steve



  • Thanks for your help!

    It is this box: https://www.applianceshop.eu/security-appliances/security-appliances-desktop-and-wallmountable/pfsense-based-desktop/opnsense-desktop.html

    I will try all the speed settings and hope for a positive result.


  • Netgate Administrator

    OK, that is built on the ALIX board which uses a default baud rate of 38,400 for accessing it's BIOS. However it can be changed so Applianceshop may have set it differently, seems unlikely though.
    This does indicate that it might be displaying the BIOS and then not booting anything for some reason. You may have to reflash the CF card if the boot loader is corrupt.

    Steve



  • OK I tried all the different speeds. 115200 was working.

    Unfortunately I only can see the effect Steve was describing above. It is booting the BIOS and then showing only two horizontal lines. (Screenshots)


    Is there any chance to save this or do I have to flash everything? I have a backup of the configuration so it shouldn't be a big problem though.

    Thanks for all your help!


  • Netgate Administrator

    Hmm, well that's not what I expected to see. The link you posted is to the exact model?
    Phil will be able to give you much better advice on this as he uses these boards daily. However as far as I know the ALIX boards don't use an AMI BIOS they use a custom tinybios:
    http://www.pcengines.ch/tinybios.htm

    Some early ALIX boards seem to use an Award BIOS but no AMI.  :-\

    Steve



  • No, the link wasn't the exact model. After some research I did the last minutes, I know it is another model. I bought it in April but the link I was getting it from doesn't work anymore. A friend just gave me the package so I don't even know the exact CPU.

    I am trying to look that up to get the right image to flash to the CF card.



  • So here is the exact data of my device.

    OPNsense Ghz - pfSense desktop & wallmountable appliance OPN-20074-B
    CPU Options
    1 x Intel Atom Z530P - 1.6 GHz
    Warranty
    1 x Standard 1yr Warranty - Parts & Labour
    Power supply [Wall mountable]
    1 x Power supply - EU plug
    Firmware options
    1 x pfSense version 2.1 [Release]
    Memory Options [2Gb requires 1.6Ghz CPU]
    1 x 2 GB RAM
    Flash Memory Upgrade Options
    1 x 4Gb Compact Flash SLC

    I am thinking of using a new CF card if the old one is the cause of the whole situation.


  • Netgate Administrator

    That BIOS output is still odd. Try pressing 'TAB' to enter the setup when it first appears.

    OPN-20074-B seems to be this:
    https://www.applianceshop.eu/opnsense-a10-dual-core-desktop.html

    But that has a different CPU and storage.  :-\

    Steve



  • I cannot press anything while booting. TAB (and also "s" which I read in another board) doesn't do anything.

    I flashed a new system to a CF card. If I boot with the CF card in I get exact the same result as shown above.
    If I boot with CF card inside with a new BIOS on it, I only get this message "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key". If I then press any key it just repeats the message again and again. CTRL + C doens't work and and break (which I can send with ZTerm) has no effect as well.

    I tried the old CF card and another one.

    Now I am at the end of my thoughts and of everything I could find on the internet.

    Any ideas?


  • Netgate Administrator

    How did you write the image to the CF card? Which image did you use exactly?

    Steve



  • I used dd on a MacBook to write the image to the CF card. I thought about trying physdiskwrite on a Windows machine to double check tonight.

    The exact line was:

    sudo dd if=/Users/XXX/Desktop/pfSense-2.1.5-RELEASE-4g-i386-nanobsd.img of=/dev/disk4
    

    Anything wrong with that?


  • Netgate Administrator

    Nope looks good. A lot of people write the gzip'd file without extracting it first.
    The output from the BIOS still seems odd to me, it doesn't look like other embedded boxes I've used. Given that the box failed to boot after a power failure and it doesn't seem to be the boot media it may be a bios issue. Could just be the cmos, you could try resetting it.
    Have you tried containing applianceshop to ask what the bios output is supposed to look like?

    Steve



  • Good idea to hard reset the CMOS. Any ideas how to that with my board? I already googling it.

    I'll attach a picture of the board.


  • Netgate Administrator

    It's this in case you hadn't realised:
    http://www.openvox.cn/products/ippbx/embedded-motherboards/127/ipc110-detail.html

    and:
    @http://www.openvox.cn/pub/misc/IPC110 Hardware Installation Guide v1.0.03.pdf:

    CN6              clear CMOS
    Setting Function
    Close 1-2 Clear CMOS
    Open 1-2 (default) Normal

    Steve



  • Thanks, I already found it!

    So just to be sure. I set the jumper plug in the power chord, wait for a few seconds, plug out the power cord, remove the jumper and that's it. Right?


  • Netgate Administrator

    Normally you would:
    Remove the power cord.
    Set the jumper.
    Wait ~30s.
    Reomve the jumper.
    Replace the power cord.

    Steve



  • Did it like this. Now all three leds are green from the beginning of booting. Nothing comes to the serial console anymore.


Log in to reply