RoadWarior VPN with same Local amd Remote Subnet



  • Hi,

    i hope somebody can help me.

    I have a working Remote VPN connection to connect to my remote 192.168.10.0/24 Network.

    The problem is i´m right now in a local network that is the same IP configuration with 192.168.10.0/24 so i can get my traffic to the remote network.

    I already configured to parse all traffic trough my VPN if established but it don´t forward my traffic because i use the local network.

    Is there a trick to fix such a thing without reconfiguring the network (i can´t change the local IP configuration to a different one).

    Thanks!



  • The recommended solution is to use different subnets on both sites, you know.

    If you try to route the same subnet over VPN as is configured on physical interface the route will be ignored.
    For workaround, you may add singular IPs you want access in the remote subnet to be routed over VPN instead of the hole subnet.
    Remember that your VPN client host cannot access the same IPs in local network while it is connected to the VPN server.



  • you can use a 1:1 NAT to create a sort of virtual subnet (with a different range) that forwards to your actual lan-subnet.



  • Thank you all so much for your feedback!

    This solution worked for me, i just added to the VPN under advanced configurtion on client side the subnet to be routed trought:

    "route 192.168.10.0 255.255.255.0"

    Tata!

    Thanks!

    @viragomann:

    The recommended solution is to use different subnets on both sites, you know.

    If you try to route the same subnet over VPN as is configured on physical interface the route will be ignored.
    For workaround, you may add singular IPs you want access in the remote subnet to be routed over VPN instead of the hole subnet.
    Remember that your VPN client host cannot access the same IPs in local network while it is connected to the VPN server.


Log in to reply