Squid + LDAP Autenticación W2K3



  • Hola a todos,
    Me permito agregar un nuevo tema ya que he gogleado y leido muchos temas parecidos aca, sin embargo no logro solucionar mi problema.
    Detallo a continuación mi escerario y mi problema

    PF : Ver 2.1.5 sobre FreeBSD 8.3-RELEASE-p16

    Hardware :Pentium(R) Dual-Core CPU E5400 @ 2.70GHz
                    2 CPUs: 1 package(s) x 2 core(s) 2GB RAM
    3 Tarjetas de Red configuradas de la siguiente forma
    VR0= WAN ->wimax static IP
    VR1 = Interface LAN Static IP
    re0= WAN Fibra Static IP

    servicios instalados :
    apinger
    dnsmasq
    ntpd
    openvpn
    squid
    squidGuard

    Ambas conexiones WAN configuradas como multiwan con failover funcionando perfectamente.

    Mi configuración del LDAP esta de la siguiente manera en servers (image1)

    Al probar la conectividad en Settings hace correctamente el Bind (Image2)

    LA configuración de mi servicio squid esta de la siguiente manera (imagen3)

    Cuando se hace el test de autenticación el usuario se valida correctamente (imagen4)

    Sin embargo cuando configuro el browser para que el usuario se autentique no funciona, al revisar el cache.log obtengo esto:
    2015/01/06 11:18:02| Accepting proxy HTTP connections at 10.10.1.12, port 3128, FD 27.
    2015/01/06 11:18:02| Accepting HTCP messages on port 4827, FD 28.
    2015/01/06 11:18:02| Accepting SNMP messages on port 3401, FD 30.
    2015/01/06 11:18:02| WCCP Disabled.
    2015/01/06 11:18:02| Loaded Icons.
    2015/01/06 11:18:02| Ready to serve requests.
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'
    squid_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'

    He probado diferentes confuguraciones sin exito, creo que mis paramentros segun lo que he consultado en multiples tutoriales estan correctos no obtante no logro autenticar los usuarios desde el browser.

    De antemano agradezco toda la ayuda que su conocimiento me pueda brindar.

    Saludos,










  • en LDAP Base domain

    DC=xxxx,DC=local -R

    para que busque Recursivamente en todo el árbol LDAP

    a mí me funcionó así en win2k3

    Abz.



  • Gracias rocaembole, ha sido se mucha ayuda su comentario, no tienes idea que llevo casi una semana lidiando con este problema, aprovechando ya que soy nuevo en el mundo de PF esta búsqueda recursiva es necesario hacerla en 2008 server ?

    Ya que estoy planeando migrar mi dominio a 2008 server.

    Saludos,



  • qué bueno que te haya servido mi experiencia.

    quizás no sea necesario en win2k8 pero yo lo tengo puesto igual ya que no resta decirle al pfsense que busque recursivamente. Antes no lo tenía y funcionaba igual en 2k8, sin el -R, pero cuando redireccioné la IP del server AD al win2k3 tuve que agregarlo, y luego lo dejé así.

    No obstante, en win2k8 no buscaría "test test" sino que sería:

    CN=test,CN=users,DC=xxxx,DC=local

    en win2k3 buscás x nombre y apellido
    en win2k8 buscás por username

    Saludos y éxitos en tus proyectos.



  • Gracias nuevamente, esa búsqueda por nombre y apellido en W2K3 también ha sido un dolor de cabeza, no sabia que la búsqueda debía hacerse con dicha sintaxis.

    Ya podré integrar el squid con autenticación LDAP en mi ambiente de producción. Otros proyectos en mente, esta herramienta es fantástica!!

    Saludos cordiales,


Log in to reply