Problème de DHCP pas DHCPREPLY



  • Bonjour,

    Je vous présente donc mon problème :)

    Contexte : Environnement pro, le PFSENSE 2.1.5-RELEASE est branché derrière un contrôleur wifi

    Besoin : Que tous les postes puissent se connecter à Internet sans problème

    Problème : J'ai 2 problèmes

    • 1er problème

    Certains postes qui ne reçois pas de configuration ip par le DHCP, le serveur envoie bien le DHCPOFFER mais il ne reçoit pas de configuration ip.

    coté logs j'ai quelque chose qui ressemble à ça :
    Jan 20 16:12:52 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:01 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:01 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:09 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:09 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:18 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:18 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:26 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:26 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:28 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:28 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:30 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:30 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:35 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:35 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:43 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:43 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:52 apollon dhcpd: DHCPDISCOVER from 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1
    Jan 20 16:13:52 apollon dhcpd: DHCPOFFER on 192.168.5.197 to 34:a3:95:b5:b4:2c (iPhone-de-Marie) via em1

    • Second problème

    J'ai bien le DHCPDISCOVER, DHCPOFFER, DHCPREPLY, DHCPACK mais le serveur n'envoie pas de configuration ip

    Pour ces 2 problèmes après plusieurs reconnexions les postes peuvent se connecter mais parfois cela reste bloquer toute la journée et généralement ce sont les journées où il y a le plus d'utilisateurs et pourtant nous avons 512 adresses avec des baux de 2h que nous n'avons pas plus 200 adresses simultanées

    Logs et tests :

    Coté serveur

    • Redémarrage du service DHCPD
    • Lors du problème redémarrage du PFSENSE
    • Augmentation de la plage d'adresse ip
    • Redémarrage du contrôleur wifi
    • MAJ du PFSENSE

    Coté client

    • Ipconfig Release / Renew
    • Redémarrage de la carte réseau
    • Redémarrage du poste

    Merci d'avance :)
    Panshir



  • le client n est il pas configuré en statique au moins?



  • Non, les clients sont tous en DHCP



  • je ne vois pas l'ack ….



  • obtenez vous une config IP valide, avec un offer, ack dans les logs, sans switche, direct au cul de la carte sur pfsense?



  • il serait bon de sniffer le reseau

    par ailleurs, 2h pour un bail dhcp > why?



  • @Florian22:

    je ne vois pas l'ack ….

    C'est normal, je n'ai extrait uniquement les logs pour mon premier problème lorsque le server n'envoie pas son DHCPREPLY et DHCPACK (mais il envoie bien le DHCPOFFER) sinon coté log pour mon deuxième problème j'ai EXACTEMENT les mêmes trames que pour un client qui a réussi à se connecter (je n'ai pas pu voir par contre voir coté client se qu'il se passait niveau trame).

    @Florian22:

    obtenez vous une config IP valide, avec un offer, ack dans les logs, sans switche, direct au cul de la carte sur pfsense?

    Disons que c'est un problème assez erratique donc très difficilement reproductible.. j'ai fais par contre un tcpdump sur le serveur et je vois exactement la même chose, il n'y a donc  pas de blocage fais par mes équipements réseaux

    @Florian22:

    il serait bon de sniffer le reseau

    par ailleurs, 2h pour un bail dhcp > why?

    J'ai déjà sniffer le réseau pour voir se qu'il se passait coté serveur/client j'ai exactement la même chose (j'ai oublier de le mettre dans les tests sorry ! ^^)

    Le PFSENSE est utilisé pour le wifi de la bibliothèque, donc pour éviter que des baux soit réserver pour des utilisateurs qui ne sont plus connecter sur le réseau.

    Niveau piste je sèche un peu :(



  • A tout hasard, pas de problème de date ou d'heure système sur les machines clientes dhcp ?



  • regardez les logs auss si vous voyez que le servce plante ?

    que faites vous lorsque cela se produit puisque vous me dites que c est aleatoire  entreprenez vous une action qui va resoudre temporairement le pb?  genre reboot?

    il serait peut etre bon d installer un mini dhcp windows sur une machine proche des users, (temporairement) et de desactiver le dhcp de pfsense.

    a ttes fins utiles de tests, de le laisser tourner 8-10 jours et de voir si le probleme se maintient



  • @ccnet:

    A tout hasard, pas de problème de date ou d'heure système sur les machines clientes dhcp ?

    Coté machine cliente non, mon portable était à l'heure et il a déjà eu le problème !

    @Florian22:

    regardez les logs auss si vous voyez que le servce plante ?

    que faites vous lorsque cela se produit puisque vous me dites que c est aleatoire  entreprenez vous une action qui va resoudre temporairement le pb?  genre reboot?

    il serait peut etre bon d installer un mini dhcp windows sur une machine proche des users, (temporairement) et de desactiver le dhcp de pfsense.

    a ttes fins utiles de tests, de le laisser tourner 8-10 jours et de voir si le probleme se maintient

    les reboot ou autres actions coté serveur ne servent à rien, même la suppression d'un bail etc.. il suffit de réessayer plusieurs fois pour réussir à se connecter.

    Je vais essayer ces 2 tests je vous tiens au courant ! si vous avez d'autres idées je suis preneur



  • a ttes fins utiles pensez egalement a collecter un "faisceau de preuves", c est a dire, a chercher un dénominateur commun a toutes les machines qui posent pb

    (réseau, segment, OS, etc etc)

    => en gros cherchez ce qui les rassemble, a part pf biensur


Log in to reply