PS3 and UPNP not working >:( - bounty 50$



  • PS3 and UPNP not working  >:( - bounty 50$

    Hello there,

    I need some help, couse I don't get the ps3 work with upnp. I get through all the forum gave me… (or I just oversaw something) and found nothing that helped me. I try to get through the ps3 network test…

    PS3 set via Mac-Adress to
    IP 192.168.2.20
    Sub 255.255.255.0
    Gate 192.168.2.1
    DNS 192.168.2.1

    IP Adress test - ok
    Internet test - ok
    PSN - ok
    UPnP - not available
    NAT-Type - Type 2
    Down - 20Mpbs
    UP - 1.9Mpbs

    I want that UPnP will be tested - ok

    If anyone can get it to work or will help me with team viewer I will donate him 50$.

    Screenshots of the actual settings are attached


    ![outbound nat.png](/public/imported_attachments/1/outbound nat.png)
    ![outbound nat.png_thumb](/public/imported_attachments/1/outbound nat.png_thumb)



  • Are you double NAT'ed?



  • Nope just from the pfsense direkt into the modem with pppoe.



  • I've never used outbound NAT rules before because my setup is simple enough to just work with automatic. I'd be curious to know if it works with automatic.


  • LAYER 8 Global Moderator

    Why do you have your ps3 setup to static outbound nat for every single port??  This make no sense…

    When I get home tonight I will fire up my son's ps3, I don't recall if tested it after moving to 2.2.  I know it worked on 2.1.5, and there were issues with psn over the xmas break, etc.  So stuff was not working correctly but do know that upnp was ok.


  • LAYER 8 Global Moderator

    Ok as I thought - click and working.  So currently running

    2.2-RELEASE (amd64)
    built on Thu Jan 22 14:03:54 CST 2015
    FreeBSD 10.1-RELEASE-p4

    Even have upnp locked down to only my sons ps3 IP.  Do you have some rules on segment ps3 is on that would block?  My lan is any any..  So attached are the settings for upnp, and pic of ps3 showing test was fine upnp avail, etc.






  • @johnpoz:

    Why do you have your ps3 setup to static outbound nat for every single port??  This make no sense…

    When I get home tonight I will fire up my son's ps3, I don't recall if tested it after moving to 2.2.  I know it worked on 2.1.5, and there were issues with psn over the xmas break, etc.  So stuff was not working correctly but do know that upnp was ok.

    Do you have static outbound NAT enabled? If so can you post your setting?


  • LAYER 8 Global Moderator

    no I don't have any static outbound set other than the default one it does for isakmp on 500..  I just have automatic set..  There is RARELY ever a reason to have to set a manual outbound, and you sure don't need static for PS3 or UPnP to work.




  • Did you get this working? I'm still on 2.1.5 and got UPnP working with my PS3 by following this guide. 
    http://pfsensesetup.com/pfsense-upnp-and-nat-pmp/

    My setup looks identical to the screenshot posted by johnpoz


  • LAYER 8 Global Moderator

    Guide – thats not a freaking guide, that is some basic concepts about what UPnP is..  And they mention pfsense 2.0  You get more info looking at the page in pfsense...



  • So after some more research and looking into a friends pfsense setup, there is something that I discovered.

    When I turn on igmp snooping in the switches, the ps3 only get NAT 2 and don't detect upnp. If I disable it
    then it will detect it. That might be the reason that ps4 lost that detection in the network settings. It might
    disturb people like me  ::).

    My settings work like posted before - igmp snooping in the switch was the reason.



  • Here's trick I use this getting full function with 2 PS3 and 2 PS4 so everything is NAT Type is 2 and UPNP is available. Here's screenshot of my settings.

    As following my instruction:
    1. Outbound NAT must be manually and look for static port for LAN, edit it and click check on static port then save settings
    2. UPNP check all as screenshot I did

    Voila! Everything should be working. I have tested Steam so it is open so is Xbox 360 and One.

    ![static port.JPG](/public/imported_attachments/1/static port.JPG)
    ![static port.JPG_thumb](/public/imported_attachments/1/static port.JPG_thumb)


Log in to reply