OpenVPN client: pfSense states for VPN not killed on reconnect?



  • Hello everyone!

    During the past few days I was able to setup pfSense and got a tremendous amount of things nicely set up thanks to the documentation, How Tos and the Forum! Thank you for that!

    Our setup is in short:

    • two WAN (cable with public IP, DSL after router where pfSense has a private IP)
    • OpenVPN server for external clients connecting to our LAN
    • OpenVPN client to connect to off-site facilites

    Everything is working very nicely, however, the cable links sometimes is dropped due to a short time with high ping time/packet losses. This causes the OpenVPN clients to reconnect, which is of course desired.

    When I however keep a ping running from my pc to a device behind the VPN, this ping will fail after the reconnection until I manually remove the corresponding state from the pfSense state list (or wait until it expires). If I keep the ping running, it won't expire and the state never gets killed.

    I was not able to find a hint on how to force the states being killed when the VPN client goes down.

    Or is there anything else I can do?

    Thanks
    -Michael


  • LAYER 8 Netgate

    This is probably what you want:

    System > Advanced, Miscellaneous Tab

    Oh.  And don't overthink it.  If it's not really a problem, don't hassle it.

    ![Screen Shot 2015-01-22 at 1.37.22 AM.png](/public/imported_attachments/1/Screen Shot 2015-01-22 at 1.37.22 AM.png)
    ![Screen Shot 2015-01-22 at 1.37.22 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2015-01-22 at 1.37.22 AM.png_thumb)



  • Hi,

    thanks for the quick reply. I tried this setting without effect (in fact, the box WAS checked, so I unchecked it. From the description, state killing takes place, when it is unchecked).

    In my understanding, it only does something, if a gateway fails. So it would kill the "normal" states of connections on my WAN gateway. However, the states of connections through my VPN are not affected and still stay in place…


Log in to reply