Nur Probleme bei der Installation. Benötige dringend Hilfe…



  • Guten Abend allerseits

    Bin gerade am Verzweifeln und hoffe auf eure kompetente Hilfe.
    Hab mir ein apu1d4 Board mit einer msata16d gekauft und möchte nun gerne pfSense installieren, woran ich aber kläglich scheitere. Hab schon etliche Foren durchgelesen und komm immer noch nicht auf einen grünen Pfad. Um pfSense auf der msata zu installieren hab ich es schon mit USB-Stick (memstick installer serial & nanobsd serial) und mit einer SD Karte (nanoBSD serial) versucht. Boot Reihenfolge hab ich auch schon einige male überprüft. Aus anderen Beiträgen entnahm ich folgende Kommandos wenn "OK" erscheint:
    set kern.cam.boot_delay="10000" jedoch erhalte ich immer eine Fehlermeldung wie set not found.

    wenn ich es dann trotzdem versuche erscheint folgendes:

    ROOT MOUNT ERROR:
    If you have invalid mount options, reboot, and first try the following from
    the loader prompt:
    
         set vfs.root.mountfrom.options=rw
    
    and then remove invalid mount options from /etc/fstab.
    
    Loader variables:
    vfs.root.mountfrom=ufs:/dev/ufs/pfsense0
    vfs.root.mountfrom.options=ro,sync,noatime
    
    Manual root filesystem specification:
      <fstype>:<device>  Mount <device> using filesystem <fstype>
                           eg. ufs:/dev/da0s1a
                           eg. cd9660:/dev/acd0
                           This is equivalent to: mount -t cd9660 /dev/acd0 /
    
      ?                  List valid disk boot devices
      <empty line="">       Abort manual input
    
    mountroot></empty></fstype></device></device></fstype>
    

    Als ich die Memstick-Installer Version versuchte kam ich gar nicht dazu set kern.cam.boot_delay="10000" einzugeben. Jedoch bootet pfSense da und ich kann den Installer wählen. Sobald er dann loslegt und versucht die Daten zu schreiben erhalte ich folgendes:

    Execution of the command
    /sbin/fdisk -I da1
    FAILED with a return code of 1
    

    Meine Quellen für die Installation waren unter anderem
    http://www.yawarra.com.au/tutorials/how-to-install-pfsense-on-an-apu
    und
    http://www.gooze.eu/howto/pfsense-installation-on-alix-apu-board-howto

    Hoffe jemand von euch kann mir dabei helfen…

    Danke schonmal

    Grüsse



  • Ich konnte es nicht lesen, aber ich denke du verzweifelst genau so wie ich an der 2.1.5er Version.

    Ich bin nicht untalentiert aber ich hab es auch nicht geschafft.  >:(

    Wenn du noch ein paar Tage warten kannst dann warte doch auf den offiziellen Release der viel viel besseren 2.2er Version, wenn du nicht warten willst, gehe auf die Seite

    https://www.pfsense.org/download/22mirror.php?section=downloads

    und lad dir das Image

    AMD64
    Live CD with installer (on USB Memstick)
    Console: Serial

    herunter hau das auf den Stick und die APU läuft in 5 Minuten.

    Ich hab es gemacht und heute problemlos das neueste Update gemacht, die APU rennt, ohne das ich noch mehr graue Haare wegen der &"ç"/((+ 2.1.5er Version bekommen hab.

    Gruss Auric



  • erstmal Danke für deine Antwort
    Gibt es den schon ein bekanntes Datum für den Release der 2.2er Version?
    eigentlich habe ich das beim ersten Versuch genau so gemacht wie du sagst und das mit dem empfohlenen m0n0wall physdiskwrite und danach auch mit dem Win32 Disk Imager.
    Dabei erhielt ich jedoch nach dem ich beim booten "I" für den Installer gewählt habe den erwähnten Fehler.

    Execution of the command
    /sbin/fdisk -I da1
    FAILED with a return code of 1
    

    Ich lass da jeweils die default Einstellungen sein und starte den Quickinstall.



  • @xybor:

    Gibt es den schon ein bekanntes Datum für den Release der 2.2er Version?

    Oh ja ;)

    https://blog.pfsense.org/?p=1546



  • Na endlich  :D



  • Hallo

    Ich kann Auric nur zustimmen. Meine Probleme waren andere Natur aber die Installation der 2.2 ging wirklich flott.:)
    Ich habe es nur 1x mit der 2.1.5 probiert und bei der erste Fehlermeldung, bin ich gleich auf die 2.2 umgestiegen.



  • Leider klappt es bei mir dennoch nicht so ganz…
    Hab gerade eben 2 usb stick vorbereitet einer mit nanobsd und der andere mit dem memstick installer (beide amd64 und serial).
    beim memstick installer hat sich nichts geändert erhalte wieder die gleiche Fehlermeldung, die Ihr im Anhang seht und hier noch die logs:

    BSD Installer started                                                    ▒
      ▒ DFUI connection on tcp:9999 successfully established                     ▒
      ▒ ,- opened pty to '/sbin/sysctl -n hw.physmem'                            ▒
      ▒ < 4225662976                                                             ▒
      ▒ `- closed pty to '/sbin/sysctl -n hw.physmem'                            ▒
      ▒ `/sbin/sysctl -n hw.physmem` returned: 4225662976                        ▒
      ▒ ,- opened pty to '/sbin/sysctl -n kern.disks'                            ▒
      ▒ < da1 da0                                                                ▒
      ▒ `- closed pty to '/sbin/sysctl -n kern.disks'                            ▒
      ▒ `/sbin/sysctl -n kern.disks` returned: da1 da0                           ▒
      ▒ Testing da1                                                              ▒
      ▒ Invoking survey for da1                                                  ▒
      ▒ Surveying Disk: da1 ...                                                  ▒
      ▒ ,- opened pty to '/sbin/atacontrol list'                                 ▒
      ▒ < /sbin/atacontrol: not found                                            ▒
      ▒ ( EOF )                                                                  ▒
      ▒ `- closed pty to '/sbin/atacontrol list'                                 ▒
      ▒ ,- opened pty to '/sbin/fdisk da1'                                       ▒
      ▒ < ******* Working on device /dev/da1 *******                             ▒
      ▒ < parameters extracted from in-core disklabel are:                       ▒
      ▒ < cylinders=3897 heads=255 sectors/track=63 (16065 blks/cyl)             ▒
      ▒ Flow executing -> main/install/centipede_confirm_basic (Confirmation     ▒
      ▒ Message)                                                                 ▒
      ▒ [Sat Apr 5 01:06:25 2014]                                                ▒
      ▒ Flow executing -> main/install/select_disk (Select Disk)                 ▒
      ▒ Flow executing -> main/install/format_disk (Format Disk)                 ▒
      ▒ ,-<<< Executing `/usr/sbin/cleargpt.sh da1'                              ▒
      ▒ | gpart: Device busy                                                     ▒
      ▒ | gpart: Invalid value for 'i' argument: Invalid argument                ▒
      ▒ | gpart: Device busy                                                     ▒
      ▒ `->>> Exit status: 0                                                     ▒
      ▒ ,-<<< Executing `/sbin/fdisk -I da1'                                     ▒
      ▒ | ******* Working on device /dev/da1 *******                             ▒
      ▒ | fdisk: /boot/mbr: No such file or directory                            ▒
      ▒ `->>> Exit status: 1                                                     ▒
      ▒ [Sat Apr 5 01:06:31 2014]                                                ▒
      ▒ ,-<<< Executing `/sbin/fdisk -I da1'                                     ▒
      ▒ | ******* Working on device /dev/da1 *******                             ▒
      ▒ [Sat Apr 5 01:06:32 2014]                                                ▒
      ▒ | fdisk: /boot/mbr: No such file or directory                            ▒
      ▒ `->>> Exit status: 1 
    

    Mit der nanobsd Version kann ich beim Starten den Installer gar nicht aufrufen… also hab ich mal das LAN Interface erfolgreich konfiguriert und bin dann in der Konsole im Menü gelandet. In älteren Beiträgen hab ich gelesen, dass ich dann mit der Eingabe "99" pfSense im nachhinein installieren kann, jedoch erhalte ich da nur die Meldung, dass er dieses lua_installer Script oder wie sich das nennt nicht finden kann...  :-
    Wer kann mir da helfen?




  • Hi,

    ich habe jetzt seit ca einen Monat eine apu1d4 und dort hat sowohl die Installation von der pfSense 2.1 als auch die der 2.2 ohne Probleme funktioniert.

    Dafür habe ich bei der Download Seite AMD(64) –> LiveCD with installer on USB memstick --> Serial genommen.

    Danach einfach mit dd auf das image auf den stick und schon kann es los gehen.

    Hast du die mSata auch auf den richtigen Port gesteckt ? Die anderen beiden Ports sind ja für mini-pcie.

    Bzw hast du die mSata mal in einem anderen Gerät getestet?



  • Danke nochmals hat komischerweise nun geklappt, hab die zwei Pins kurzgeschlossen um CMOS zu löschen, dann funktionierte es.
    Wie das zusammen hängen soll versteh ich auch nicht… :)


Log in to reply