2.2 i386 (upgrade) - appears squid 2.7.9 package is broken



  • after successful package installation, squid is not running, this is found in the system logs:

    
    php-fpm[79476]: /pkg_edit.php: The command '/usr/pbi/squid-i386/sbin/squid -D' returned exit code '1', the output was 'Shared object "libz.so.5" not found, required by "libmd5.so.1"'
    
    

    Tried reinstalling a few times with no luck.



  • Try  squid3 as squid2 has been removed from ports.



  • Hello,

    I had the same issue this morning. From an existing installation of pfSense 2.1 + Squid, I copied the following files onto my upgraded pfSense 2.2 system:

    /lib/libz.so.5
    /lib/libcrypto.so.6
    /usr/lib/libssl.so.6

    Squid works fine now.

    Hope this helps.



  • I have been using Squid3 on 2.1.x but it doesn't appear to work reliably on my 2.6GHz Celeron with 1GB RAM running 2.2 (i386) with transparent proxying switched on.

    I have also experienced problems daily with the webgui not responding but fortunately I can ssh into the console and option 16) Restart PHP-FPM usually gets the webgui operational again. If I uninstall Squid3 the webgui appears to run fine.

    I liked Squid3 but I need transparent proxying more. I hope it still works in 2.7.9 .



  • Squid3 pbi on i386 will be updated to fix missing transparent proxy compile option(you can confirm executing  squid  -v on console / ssh.

    On amd64 it's transparent proxy is working fine.



  • Thanks. I appreciate your effort to fix this.

    In the old days, I used conditional branching proxy.pac files and I still think that it's a better way than transparent TCP interception. I'm going to have a go setting up wpad with dhcp delivery and see how I get on with that for now.

    http://wiki.squid-cache.org/SquidFaq/ConfiguringBrowsers#Fully_Automatic_Configuration





  • @jesus_seba:

    Hello,

    I had the same issue this morning. From an existing installation of pfSense 2.1 + Squid, I copied the following files onto my upgraded pfSense 2.2 system:

    /lib/libz.so.5
    /lib/libcrypto.so.6
    /usr/lib/libssl.so.6

    Squid works fine now.

    Hope this helps.

    Any chance of the pfSense dev team getting a 2.2.1 update out soon with these missing files included? A lot of us are still using Squid 2.x with pfSense because it works well and stable on older hardware.


  • Rebel Alliance Developer Netgate

    Those files aren't missing. Those are old versions. pfSense 2.2 uses (for example) libz.so.6, libcrypto.so.7 and libssl.so.7.

    If something is looking for the old versions, it must not have been compiled properly.

    Maybe the PBI that was installed was still the old 2.1 PBI?

    Uninstall all of the squid related packages, check "pbi_info" from the shell and "pbi_delete" any squid packages that still show up, then install it again.



  • I have regressed my main firewall back to 2.1.5 today and edited the config.xml by hand and with diff/patch from known good backups. It's working fine again now.

    I am planning to get 'new' hardware next week so that I can build the config from scratch on a 64bit version of 2.2 .

    One thing I have learned from this experience is that I need to build my own test scripts for what's important for my installation. I completely forgot to test something that was important to my site during the entire 2.2RC period despite testing a load of other stuff on a 2.2RC machine before release day.



  • squid 3 on i386 seems not to being recompiled for transparent proxy at the moment isn't it?

    And squid2 pbi seems to be wrong too.

    Any other solution?

    I downgraded until we got a solution for this problem.



  • @NetVicious:

    squid 3 on i386 seems not to being recompiled for transparent proxy at the moment isn't it?

    based on a few other threads, looks like the pbi for i386 came out yesterday.



  • @Cino:

    looks like the pbi for i386 came out yesterday.

    Yes, it fixed most compile issues for i386.



  • I've just installed 3.4.10_2 pkg 0.2.6 and I'm seeing the following config using "squid -v".

    '--disable-ipf-transparent' '--disable-ipfw-transparent' '--enable-pf-transparent'
    

    This is the same as before.  :(

    Steve



  • Is the phi that came out yesterday for squid 2 or 3?

    Steve



  • @Steve:

    This is the same as before.  :(

    The transparent pf is what we need  '–enable-pf-transparent' to get transparent proxy working.

    Are you still with issues?

    @Steve:

    Is the phi that came out yesterday for squid 2 or 3?

    squid3



  • Yes, still not working. My previous investigation of this showed the redirection wasn't working, but then you spotted the compile options.

    Confused.

    Steve





  • Perfecto, gracias!!!


Log in to reply