Upgrade from 2.1.5 to 2.2 hangs on boot.



  • Let me start with the disclaimer that I am a Unix noob, so please be gentile and specific.  Thanx. :)

    Had 2.1.5 running fine through many in-place upgrades on an old (~7 year) MPC workstation with generic Intel guts (Motherboard & chipset).  Got the email that 2.2 was in general release, so I figured I'd upgrade through the console.  The upgrade proceeded and after an hour I figured something was wrong, so I hooked up a monitor to the box and the screen is filled with:

    (aprobe0:ata0:0:0:0): SETFEATURES SET TRANSFER MODE.  ACB: ef 03 00 00 00 40 00 00 00 00 08 00
    (aprobe0:ata0:0:0:0): CAM Status: Command Timeout
    (aprobe0:ata0:0:0:0): Retrying command

    I have tried rebooting, reloading defaults in the BIOS, changing the drive in the GIOS from IDE to SATA and back, etc. but I have no idea how to get to any of the prompts I've seen in various other threads of boot issues.  I suspect it is the drive handling change mentioned in the docs, but I have not seen how to get to anywhere that I can make changes.  Any help is greatly appreciated.  Thanx!

    EDIT:  The hardware specs are:
    http://www.cnet.com/products/mpc-clientpro-585-core-2-duo-e6700-2-66-ghz/specs/



  • Do you have a config backup?
    On release notes there is a script that helps disk name changing,  did you run it before upgrading?

    If other boot threads do not show you  a way to boot,  try  a clean install snd partial config restore. (ips,  aliases, gateways,  rules,  etc).

    This thread csn also help
    https://forum.pfsense.org/index.php?topic=87330.0



  • I selected the checkbox in the web interface to make the backup, but it didn't ask me anything after that.

    And no, all I did was click the update link from the main page on the web console.



  • Without  a xml backup file,  I suggest you watching other boot failure tests.

    It's 5am here in Brazil, I need some sleep time now.
    Good luck.



  • It seems there is a similar post regarding this:

    https://forum.pfsense.org/index.php?topic=87364.0



  • OK, I found an old Knoppix disk and have booted the box from that.

    What file do I need to edit on the hard disk to change the drive mounting?  Is it etc/fstab?



  • https://doc.pfsense.org/index.php/Boot_Troubleshooting

    Lots of info there, just found the article.



  • but yet, if its a label issue vi or nano    /etc/fstab

    newer labels should follow the adaX versus adX convention. or daX for USB drives as far as i remember.

    Please note that most ( or maybe all ) SD card would probably show up as daX because there is always some kind of SD card to USB converter chip. Maybe for CF also ? but CF is the same as IDE, really .. so maybe not CF… not sure.



  • Thanx!  Now if I could only get to the file…  Knoppix throws an error trying to mount the drive.

    Knoppix HD tool shows the drive as good, but the partition is grey and when I try "mount -t ext3 /dev/sda1 /mnt/hd" I get the "Mount: wrong fs type, etc."

    The pfsense file system is ext3, right?


  • Banned

    @fillmoreb:

    The pfsense file system is ext3, right?

    No. UFS.



  • no, pfsense is a UNIX system not linux, UNIX uses ufs or ZFS with newer options.

    So really, you want to boot into something like PCBSD if you want GUI access. If you want command line only, you could probably just boot from a pfsense CD and go into command line from the options ? i think there is rescue option ?

    I'm going to be honest, i don't think this is a label issue… maybe FreeBSD 10.1 doesn't like something about your hardware. Maybe try booting form different boot media like a USB stick or SSD or whatever, not sure what you are currently using...

    And if you are going to install pfsense 2.2 on a USB stick, choose the NanoBSD version download and if you have a VGA port, the VGA console version. I would remove your current boot media tho.

    Choose an image size that is close to your USB ( not over ), then you will have to write the image file into the USB stick with something like http://sourceforge.net/projects/win32diskimager/



  • look at the post form phil.davis here:

    https://forum.pfsense.org/index.php?topic=87364.0



  • OK, so I have tried everything I can think of to gain access to that drive to check and/or edit the file to no avail…

    I was able to get the pfsense 2.2 live CD and boot it to a prompt, but still can't figure out how to access the hard disk.

    As I said earlier, I'm a total noob here so detailed instructions would be appreciated.  Thanx!



  • Being a Unix noob shouldn't hurt you here as long as you are a BSD expert (-;

    (I'm not - Looks like a few showed up though)



  • based on the post there by phil, like i said i don't think your issue is the label.

    Have you tried doing a fresh install on a USB disk with the current boot disk removed and see if it works ? A few people are talking about the same issue now and most of them said they went back to 2.1.5 … but if its the ATA controller FreeBSD 10 doesn't like form your system or something, installing a nanoBSD version to a USB drive should work.

    Here is link to download: https://www.pfsense.org/download/download.php?url=http%3A%2F%2Ffiles.atx.pfsense.org%2Fmirror%2Fdownloads%2FpfSense-2.2-RELEASE-4g-amd64-nanobsd-vga.img.gz

    Then extract the gz file and write the img file to a USB stick with something likehttp://sourceforge.net/projects/win32diskimager/

    That image is for 64 bit system ... if you have 32 bit this one should work:https://www.pfsense.org/download/download.php?url=http%3A%2F%2Ffiles.atx.pfsense.org%2Fmirror%2Fdownloads%2FpfSense-2.2-RELEASE-4g-i386-nanobsd-vga.img.gz



  • No, I've been trying everything I can think of to avoid a reinstall.

    I ran fdisk at the pfsense shell and am getting "fdisk: mounted root fs resource doesn't match expectations (regexec returned 1)"

    Is there a way to roll back to 2.1.5?

    I have to have something working in about 2 hours…  :P

    Thanx for all the help. :)



  • How highly configured was your pfsense?  Lots of settings and packages or basic and simple config?



  • I was pretty simple I think, compared to most of the other peoples.  Just served up IPs, and rules for access times, Squid, Dansguardian, etc.

    So, yes, I'm starting to think reloading it might be the quickest solution at this point.



  • I did a fresh install of 2.2 on a couple and restored a backup config from 2.1.5 because I had not provisioned as much disk space as I'd like and decided to correct that error.  They work fine.  When you reconfigure, remember to make a backup of your configuration this time if you don't already have one.  Keep it handy.



  • Yep…  I assumed checking the box to backup the config during the upgrade would give me the backup file, but it did not...  I brought the box into the office where I have more resources to troubleshoot and investigate, so I don't have access to see when the last backup I took of it was.  Hopefully it will restore and will have most of what I need on it.

    OK, here goes a fresh install of 2.2 from the LiveCD.  Wish me luck. :)



  • Good luck.


  • Netgate Administrator

    The checkbox does give you a full backup. See:
    https://doc.pfsense.org/index.php/Full_Backup

    If you can get to a command prompt you can probably restore it.
    You could copy the backup file off the disk somehow, I've used a GhostBSD live CD successfully for such things before.

    Steve



  • Well, looks like reqlez was correct; 2.2 is just not compatible with my hardware for some reason…  Fresh install of 2.2 gives me the same messages on first boot.

    Guess I need to go back to 2.1.5. :(



  • I saw that another guy got pfsense to work by restoring his MB config to default.
    I'd try alot of things before rolling back.



  • Yea, I have tried that and more in the BIOS as well…

    I've been working on this for ~15 hours now; I can't think of anything else to try.

    Since the fresh 2.2 install did the same thing, all I can do is reinstall 2.1.5 again and hope I have a backup somewhere.


  • Netgate Administrator

    You will have a backup file on the drive (since you checked the box) but it will be overwritten if you choose to reinstall.

    Oh wait you already did that.  :(

    Steve



  • I'm wondering about his SATA.  Would it matter which sata slot his cable is plugged into?

    I know OSs can sometimes be picky about it.



  • The hard drive is the only SATA device in the system.  The DVD ROM is IDE (That's how old the thing is.  lol)

    So, to end my tale…  ;)

    I wiped the box and installed 2.1.5 64-bit from disk without incident.  I couldn't find a backup anywhere, so I had to reconfigure everything.

    All in all it will be a good thing.  I got the BIOS straightened out (the HD controller was in IDE compatibility mode; it is now in SATA mode), the OS is now 64-bit (the original was 32-bit), and I'm far more familiar with the system than I was 2 years ago when I built the original so the reconfig only took a couple of hours.  I still need to redo the Dansguardian, Squid, Squidguard, Snort, etc., but the major stuff is back online.

    Hopefully we can figure out what in 2.2 doesn't like what in my box so I can eventually upgrade it to get the latest goodies.  Or maybe I just need to use a more modern box...  ;)

    Thanx to all who helped out.  :)


Log in to reply