Pfsense 2.2 Interface advanced dhcp client configuration



  • For some ISP's in Switzerland we need to set DHCP option 60 (dhcp-class-identifier) to receive a ip on wan interface.

    In the older pfsense versions i set it directly in the /etc/inc/interfaces.inc file like this:

    $dhclientconf .= <<<eod<br>interface "{$wanif} {
    send dhcp-class-identifier "100008,0001,,pfsense dhclient 2.1";

    Now in pfsense 2.2 i want to use the new possibility in the web ui. interfaces --> wan --> DHCP Client Configuration --> Advanced (checkbox) --> send options

    i put this in the textfield:
    dhcp-class-identifier "100008,0001,,pfsense dhclient 2.1";

    But i do not receive a ip address.

    What syntax do i have to use in the web interface?
    Do i have to use the Delimiter (space, colon, hyphen, or period) (omitted for none). to make it work?</eod<br>



  • Hello,

    I have the same problem, have you find a solution ?

    Thanks



  • Now I spend again some time on this issue.

    I Checked the log with Wireshark and now i know the problem.

    The problem is that pfsense web gui do not accept a "," (column) in the text field of dhcp-class-identifier.

    If i put this in the Advanced Config of the WAN interface (Web UI):
    dhcp-class-identifier "100008,0001,,pfsense dhclient 2.1"

    The output (in Wireshark) is:
    100008;\n\tsend 001;\n\tsend ;\ blabla

    The columns (,) are replaced with ";\n\tsend".

    Is there any way to put a column in the field? Or e escape code etc.?


  • Banned



  • Ok. Thank you for this information.

    Do I have to create a bug report or something else?


  • Banned

    Well yes if you want that fixed.



  • Try using the config file override option to specify a your custom DHCP client config file to use.


Log in to reply