Ath0 countrycode



  • Hello,

    i want more 11a channels. so i tried to modify the countrycode to germany.

    ifconfig ath0 list freq

    Channel  1 : 2412* Mhz 11g          Channel  10 : 2457* Mhz 11g
    Channel  2 : 2417* Mhz 11g          Channel  11 : 2462* Mhz 11g
    Channel  3 : 2422* Mhz 11g          Channel  12 : 2467* Mhz 11g
    Channel  4 : 2427* Mhz 11g          Channel  13 : 2472* Mhz 11g
    Channel  5 : 2432* Mhz 11g          Channel  14 : 2484* Mhz 11b
    Channel  6 : 2437* Mhz 11g          Channel  34 : 5170* Mhz 11a
    Channel  7 : 2442* Mhz 11g          Channel  38 : 5190* Mhz 11a
    Channel  8 : 2447* Mhz 11g          Channel  42 : 5210* Mhz 11a
    Channel  9 : 2452* Mhz 11g          Channel  46 : 5230* Mhz 11a

    sysctl -a dev.ath.0

    dev.ath.0.%desc: Atheros 5212
    dev.ath.0.countrycode: 392
    dev.ath.0.regdomain: 64

    cat /boot/loader.conf


    dev.ath.0.countrycode=276
    hw.ath.countrycode=276

    i tried to set the countrycode to germany in the loader.conf.
    as you can see the sysctl still displays dev.ath.0.countrycode as japan.
    anyone an idea how to set the countrycode or what mistake i do?
    has anyone more information about regdomain?

    thx.

    Martin



  • Hello,

    after playing around with a software named "Channel set utility" i get for my wlan card the following error message during boot (dmesg)

    ath1: unable to collect channel list from hal; regdomain likely 96 country code 276
    device_attach: ath1 attach returned 22

    so switching to other channels will be disabled from the HAL driver. is there anyone outside who can give me more backround information or an hint where to continue my investigation?

    For all others who buy an atheros card: take care which country code this card has. if you get one with japan country code in europe that the card can not be adjuted to all 11a channels.

    Martin



  • Hi everybody again,

    so i solved the problem. here my short summary. please write an PN if you have further questions.

    if you buy an atheros miniPCI wlan card, run it with pfsense and get only 4 11a channels then have a look at "sysctl -a dev.ath.0.countrycode" in an terminal window. if its something like 392 then you get an japan restricted version (with oly 4 11a channel in 5GHz band).
    my solution for this: if you have an miniPCI to PCI adapter download the "Channel set utility", put the card into an windows xp pc and unlock all channels.
    after this you but your card back into your pfsense system (in my case an WRAP board). don't put any countrycode etc in loader.conf. then you get such a nice channel list

    ifconfig ath0 list freq

    Channel  1 : 2412  Mhz 11g          Channel  48 : 5240* Mhz 11a
    Channel  2 : 2417  Mhz 11g          Channel  52 : 5260* Mhz 11a
    Channel  3 : 2422  Mhz 11g          Channel  56 : 5280* Mhz 11a
    Channel  4 : 2427  Mhz 11g          Channel  60 : 5300* Mhz 11a
    Channel  5 : 2432  Mhz 11g          Channel  64 : 5320* Mhz 11a
    Channel  6 : 2437  Mhz 11g          Channel 100 : 5500* Mhz 11a
    Channel  7 : 2442  Mhz 11g          Channel 104 : 5520* Mhz 11a
    Channel  8 : 2447  Mhz 11g          Channel 108 : 5540* Mhz 11a
    Channel  9 : 2452  Mhz 11g          Channel 112 : 5560* Mhz 11a
    Channel  10 : 2457  Mhz 11g          Channel 116 : 5580* Mhz 11a
    Channel  11 : 2462  Mhz 11g          Channel 120 : 5600* Mhz 11a
    Channel  12 : 2467* Mhz 11g          Channel 124 : 5620* Mhz 11a
    Channel  13 : 2472* Mhz 11g          Channel 128 : 5640* Mhz 11a
    Channel  14 : 2484* Mhz 11b          Channel 132 : 5660* Mhz 11a
    Channel  34 : 5170* Mhz 11a          Channel 136 : 5680* Mhz 11a
    Channel  36 : 5180* Mhz 11a          Channel 140 : 5700* Mhz 11a
    Channel  38 : 5190* Mhz 11a          Channel 149 : 5745* Mhz 11a
    Channel  40 : 5200* Mhz 11a          Channel 153 : 5765* Mhz 11a
    Channel  42 : 5210* Mhz 11a          Channel 157 : 5785* Mhz 11a
    Channel  44 : 5220* Mhz 11a          Channel 161 : 5805* Mhz 11a
    Channel  46 : 5230* Mhz 11a          Channel 165 : 5825* Mhz 11a

    Martin



  • Nice but where are the turbo channels or is that card not turbo capable?



  • Hi hoba,

    you are right. i have an atheros AR5004X (http://www.atheros.com/pt/AR5004XBulletin.htm) which normaly supports this 108Mbps turbo mode. i have never seen this mode in my list. i think there is an eeprom where countrycode etc is stored and all futures are enabled.
    has anyone a datasheet about the AR5213 Multiprotocol MAC/baseband processor and can figure out that? or send it to me i will have a look at it.

    Martin



  • This is what my card shows withou patching anything, however I'm missing turbo g channels:

    $ ifconfig ath0 list channel
    Channel  1 : 2412  Mhz 11g          Channel  48 : 5240  Mhz 11a         
    Channel  2 : 2417  Mhz 11g          Channel  50 : 5250  Mhz 11a Turbo   
    Channel  3 : 2422  Mhz 11g          Channel  52 : 5260  Mhz 11a         
    Channel  4 : 2427  Mhz 11g          Channel  56 : 5280  Mhz 11a         
    Channel  5 : 2432  Mhz 11g          Channel  58 : 5290  Mhz 11a Turbo   
    Channel  6 : 2437  Mhz 11g          Channel  60 : 5300  Mhz 11a         
    Channel  7 : 2442  Mhz 11g          Channel  64 : 5320  Mhz 11a         
    Channel  8 : 2447  Mhz 11g          Channel 149 : 5745  Mhz 11a         
    Channel  9 : 2452  Mhz 11g          Channel 152 : 5760  Mhz 11a Turbo   
    Channel  10 : 2457  Mhz 11g          Channel 153 : 5765  Mhz 11a         
    Channel  11 : 2462  Mhz 11g          Channel 157 : 5785  Mhz 11a         
    Channel  36 : 5180  Mhz 11a          Channel 160 : 5800  Mhz 11a Turbo   
    Channel  40 : 5200  Mhz 11a          Channel 161 : 5805  Mhz 11a         
    Channel  42 : 5210  Mhz 11a Turbo    Channel 165 : 5825  Mhz 11a         
    Channel  44 : 5220  Mhz 11a

    My card seems to be running "0" already:

    $ sysctl -a dev.ath.0
    dev.ath.0.%desc: Atheros 5212
    dev.ath.0.%driver: ath
    dev.ath.0.%location: slot=13 function=0
    dev.ath.0.%pnpinfo: vendor=0x168c device=0x0013 subvendor=0x185f subdevice=0x1012 class=0x020000
    dev.ath.0.%parent: pci0
    dev.ath.0.smoothing_rate: 95
    dev.ath.0.sample_rate: 10
    dev.ath.0.countrycode: 0
    dev.ath.0.regdomain: 0
    dev.ath.0.debug: 0
    dev.ath.0.slottime: 9
    dev.ath.0.acktimeout: 25
    dev.ath.0.ctstimeout: 25
    dev.ath.0.softled: 0
    dev.ath.0.ledpin: 0
    dev.ath.0.ledon: 0
    dev.ath.0.ledidle: 2700
    dev.ath.0.txantenna: 0
    dev.ath.0.rxantenna: 2
    dev.ath.0.diversity: 1
    dev.ath.0.txintrperiod: 5
    dev.ath.0.diag: 0
    dev.ath.0.tpscale: 0
    dev.ath.0.tpc: 0
    dev.ath.0.tpack: 63
    dev.ath.0.tpcts: 63
    dev.ath.0.rfsilent: 1
    dev.ath.0.rfkill: 1
    dev.ath.0.monpass: 24

    This is a CM9 bought from PC Engines btw.



  • Hello hoba,

    it seems to be a problem of this hal driver:
    http://www.fehu.org/atheros-en.html#modes

    Martin



  • @MdeWendt:

    Hello hoba,

    it seems to be a problem of this hal driver:
    http://www.fehu.org/atheros-en.html#modes

    Martin

    That's so strange because the linux and BSD drivers use the same HAL,when I list the channels in linux there's a couple 11g turbo channels.
    So what's up with the BSD drivers?



  • AFAIK, the linux driver has the same HAL if it's the normal madwifi driver. The madwifi-ng driver is different iirc.


Locked