Kernel: KLD vmxnet.ko error in log after 2.1.5–>2.2 update (everything works)



  • is this anything to be worried about?
    this is x64 VM running on esxi 4.1  still using legacy em nics.
    i'm guessing to use the vmxnet drivers i'll have to update to esxi 5.x ??

    
    Jan 28 10:44:22 	sshlockout[48107]: sshlockout/webConfigurator v3.0 starting up
    Jan 28 10:44:22 	kernel: linker_load_file: Unsupported file type
    Jan 28 10:44:22 	kernel: KLD vmhgfs.ko: depends on kernel - not available or version mismatch
    Jan 28 10:44:22 	kernel: linker_load_file: Unsupported file type
    Jan 28 10:44:22 	kernel: KLD vmblock.ko: depends on kernel - not available or version mismatch
    Jan 28 10:44:22 	login: login on ttyv0 as root
    Jan 28 10:44:22 	kernel: linker_load_file: Unsupported file type
    Jan 28 10:44:22 	kernel: KLD vmxnet.ko: depends on kernel - not available or version mismatch
    Jan 28 10:44:22 	kernel: linker_load_file: Unsupported file type
    Jan 28 10:44:22 	kernel: KLD vmmemctl.ko: depends on kernel - not available or version mismatch
    Jan 28 10:44:21 	kernel: done.
    Jan 28 10:44:21 	php-fpm[31601]: /rc.start_packages: Restarting/Starting all packages.
    Jan 28 10:44:21 	kernel: done.
    Jan 28 10:44:21 	syslogd: kernel boot file is /boot/kernel/kernel
    Jan 28 10:44:21 	syslogd: exiting on signal 15
    Jan 28 10:44:21 	kernel: Starting syslog...
    Jan 28 10:44:21 	php: rc.bootup: Finished reinstalling all packages.
    Jan 28 10:44:21 	php: rc.bootup: Finished installing package Quagga OSPF
    Jan 28 10:44:21 	php: rc.bootup: Successfully installed package: Quagga OSPF.
    Jan 28 10:44:21 	check_reload_status: Syncing firewall
    Jan 28 10:44:18 	kernel: 100%
    Jan 28 10:44:13 	kernel:  100%
    Jan 28 10:44:12 	kernel:  90%
    Jan 28 10:44:11 	kernel:  80%
    Jan 28 10:44:10 	kernel:  70%
    
    


  • Hi

    For now Vmware is not supporting FreeBSD version 10. You must wait with upgrade to VSphere 6.

    Regards



  • That's just from the old kernel modules still being there from the 2.1x package. The vmxnet driver is built-in to the OS in 2.2 so those aren't necessary. Uninstall and reinstall the package again and see if that goes away.

    @triptic:

    For now Vmware is not supporting FreeBSD version 10. You must wait with upgrade to VSphere 6.

    Huh? FreeBSD 10 works very well in vSphere 4.x and 5.x. With things like built-in vmxnet drivers, it's better than any previous version for VMware.


  • Banned

    Can you pls. then remove the following kernel modeuls in the open vm tools package:

    vmmemctl.ko
    vmxnet.ko
    vmblock.ko
    vmhgfs.ko

    These files have a version mismatch on the console running Vsphere 4.1, 5.0, 5.5.


Log in to reply