DNS Forwarder und Resolver



  • Moin

    Nur mal zu meiner eigenen Erhellung.

    Auf meiner PF nutze ich OpenVPN und habe kein Glück mit dem DNS, wenn vom OVPN Client ein Name aufgelöst werden soll.

    Auf allen Interfaces lauscht der DNS Forwarder. Im General Setup sind bei den DNS Servern die von Google und die WAN IP des PF eingetragen.

    Aber ein DNS Resolver läuft nirgends. Wo soll denn die Info herkommen, welchen Namen das NAS oder ein Win PC oder so hat.?

    Von Googles 8.8.8.8er oder der FB am WAN wohl nicht, oder.?

    Muss dann nicht zumindest im LAN der DNS Resolver an.? Und der erhält dann auch die Namen vom DHCP, wenn der die bei der IP Vergabe erhält vom Client…??!! Bin etwas verwirrt bzgl. DNS.



  • Reply myself..;)

    Offensichtlich kann der Forwarder das doch alles mitabdecken.

    Konnte aber trotzdem den Namen des NAS nicht pingen..

    Hab im Forwarder den jetzt manuell zugeordnet. Der DNS der PF hatte wohl keine Kenntnis vom Namen des NAS wohl wegen der static IP..?!



  • So ganz läuft das doch nicht.

    Auf dem Client, verbunden mit OpenVPN, kann ich mit nslookup hostname die passende IP abfragen.

    Ein Ping geht aber nicht. Wenn ich aber hostname.domain.com eingebe, dann wird das aufgelöst.

    Die Domain ist die, die im General Setup angegeben ist. Das ist eine .com, die via freedns an die IP des DSL
    angebunden ist.

    Sollte man besser bei einer Firewall eine domain.local nehmen.?

    Wenn ich im Win Client  im Explorer dann eine Windows Freigabe im selben Netz mit \hostname.domain.com\ eingebe, werden auch deren Freigaben gelistet. Aber ohne die Domain nicht.

    Kurios..

    So, wer hat da einen Reim drauf.?? Freiwillige vor.;)



  • Niemand ne Idee.?

    Das mit dem Resolver und Forwarder…

    Irgendwas hat sich jetzt doch erst kürzlich geändert bzgl. DNS.?

    Gibt es da evtl. noch Probleme.?

    Ersetzt der Forwarder den Resolver..?



  • Hallo habe vor kurzem selber eine VPN Verbindung für meine Firewall eingerichtet und habe dafür folgende anleitung zu rate gezogen vielleicht hilft dir das weiter.

    https://airvpn.org/topic/11245-how-to-set-up-pfsense-21-for-airvpn/



  • Interessant.

    Mal schauen. Aber ob das noch alles so passt.? Die Entwicklung bleibt ja nicht stehen…

    Das ist ja alles anders.. Sehr informativ. Aber ich hab nur noch ein Problem bzgl. DNS.


  • Rebel Alliance Moderator

    Das mit dem Resolver und Forwarder…
    Ersetzt der Forwarder den Resolver..?

    Ja. Forwarder == dnsmasq, Resolver == unbound. Das sind im Prinzip zwei Daemons die einen ähnlichen (nicht gleichen) Job machen.

    Doku dazu:
    "Unbound requires that the DNS Forwarder be disabled or be moved to a different port. They provide the same functionality on the same port, so they cannot both bind to port 53 to provide DNS services."

    Siehe: https://doc.pfsense.org/index.php/Unbound_DNS_Resolver

    Unbound (Resolver) ist für neue 2.2 Installationen nun auch Default, solange es aber keine großen DNS Anforderungen gibt, ist es m.W. recht egal welchen von beiden man nutzt, wenn 99% der Zugriffe eh nur weitergeleitet werden.



  • Finde das etwas verwirrend.

    Wenn wie in "meinem" Setup der Forwarder aktiv ist, und bei dem VPN die Windows Kisten einen DNS nach Windows PCs fragen, wo landet denn dann diese Frage.?
    Ich hab im VPN den LAN Port angegeben. Aber stimmt das denn dann.?

    Sollte ich also den Forwarder bei mir deaktivieren und den Resolver wählen.?

    Das der Forwarder bei mir aktiv ist, liegt daran das es ein Upgrade von der 2.1.x hier ist.?



  • Moin

    Greife meinen eigenen Thread nochmal auf.

    Hab zwei APUs mit aktueller pfsense als site to site VPN in Verwendung. Die Objekte sind Schulen und haben eine eigene Intrastuktur, auf die ich wenig Einfluss habe, ausser Portweiterleitungen anlegen zu lassen.
    Die Daten wie WAN IP und Gateway sowie DNS habe ich statisch eingetragen. Ping ins Internet zu 8.8.8.8 läuft auch alles. Aber DNS macht Probleme. Auf der PFsense klappt die DNS Abfrage. Auf den Clients nicht. Obwohl per DHCP den Clients das Gateway bzw. DNS mitgeteilt wird (die LAN IP). Hab dann mal testweise statt den default Resolver den Forwarder aktiviert. Damit läuft es sofort.

    An anderen Anschlüssen mit Fritzboxen als Gateway geht der Resolver einwandfrei. Wo könnte der Grund liegen.?


    Rüdiger


Log in to reply