SquidGuard 3 проблема запуска


  • Добрый день.

    Поставил на Virtualbox pFsense 2.2 (i386), на чистую сборку через Packages установил squid 3 (т.к. у него в transparent-mode нет конфликта с https), поставил squidGuard.
    Сервис guard'а не стартует (Apply жал, настройки все дефолтные), в /var/squid/log/cache.log вижу строчки:

    2015/02/01 20:50:36 kid1| WARNING: redirector #Hlpr0 exited
    Shared object "libdb-5.3.so.0" not found, required by "squidGuard"

    Сам файл libdb-5.3.so пришлось вручную искать-закидывать в /usr/lib/
    Дальше самокопания застопорились. Пробовал HAVP ставить-активировать, он тоже не стартует (как, впрочем, и clamav).

    Сам я человек пока что неопытный в nix-делах, поэтому прошу о помощи. Третий день гугления не дал ничего (или дал, но я не увидел).


  • Сам я человек пока что неопытный в nix-делах, поэтому прошу о помощи.
    Ставь версию 2.15
    http://files.atx.pfsense.org/mirror/downloads/

    ( версия 2.2 сыровата


  • Друзья, если на 2.1.5 у кого без проблем будет  эта связка - отпишите, пожалуйста. Ибо начинал пробовать на 2.1.5 пару недель назад - помню тоже какие то проблемы были с этой связкой.


  • Мучился я с этим squidGuard3 уже неделю, т. к. нужно заблокировать https трафик на объектах.
    Ставился я pfsense 2.1.5 и 2.2, и 32 и 64 битный, но всё ровно постоянно падал squidGuard3.
    Пробовал разные методы с зарубежных веток, но не помогала.
    При очередных манипуляциях я увидел в логе проблемы с доступом к tmp папке, поставил на неё полные права и на данный момент всё работает стабильно.


  • В pfsense 2.1.5 нормально работает squid3 + squidguard3, ставил Squid3-dev +squidguard3 то squidguard не стартует


  • @blexen:

    В pfsense 2.1.5 нормально работает squid3 + squidguard3, ставил Squid3-dev +squidguard3 то squidguard не стартует

    У меня на данный момент работает именно связка Squid3-dev +squidguard3, т .к. в просто squid3 не нашел настроек https


  • @yragan:

    При очередных манипуляциях я увидел в логе проблемы с доступом к tmp папке, поставил на неё полные права и на данный момент всё работает стабильно.

    А какая версия PfSense? Это папка /tmp ?


  • На данный момент стоит PfSense 2.1.5 64 бит, да именно папка /tmp.
    С последней версией PfSense не экспериментировал, т. к. немного устал от этого процесса, пока работает.


  • @yragan:

    @blexen:

    В pfsense 2.1.5 нормально работает squid3 + squidguard3, ставил Squid3-dev +squidguard3 то squidguard не стартует

    У меня на данный момент работает именно связка Squid3-dev +squidguard3, т .к. в просто squid3 не нашел настроек https

    У меня раньше связка стояла Squid3-dev +squidguard3 работала а щас поставил не работает


  • @yragan:

    С последней версией PfSense не экспериментировал, т. к. немного устал от этого процесса, пока работает.

    Друзья, кто на PFSense с давних времен, у них что, такая петрушка от версии к версии? Ситуация, имхо, нездоровая какая то ниразу…
    Думаю, то ли ждать пока пофиксят, то ли плюнуть, если такое для разрабов - обычное дело и уйти на другой более стабильный, но с меньшими возможностями, продукт


  • Убрать "самозакинутый" файл.
    Удалит Squid 3

    Как вариант поставить сначала предыдущую версию Squid, а потом уже ставить третью. после удалить старую. И попробовать.

    По поводу ошибок:
    Не ошибается тот, кто ничего не делает. Скажу по опыту: на данный момент пфсенс является лучшей системой данного плана в удобстве настроек и гибкости. Поэтому надо написать в службу на инглиш и все поправят. У меня так с фильтром было. Написал, поправили.