Cannot change or delete an LDAP server



  • Hello.  I have been troubleshooting issues with LDAP on a 2.1.5 pfsense firewall. I have two firewalls on different networks, but otherwise on the same versions of software, etc.  One can connect to it's LDAP server, the other cannot.  I tried searching the forum for similar issues, but  did not find any, but I may be searching for the wrong thing.

    I loaded the LDAP troubleshooting tool on both gateways, and was still able to make changes to the LDAP server entires on both after that.

    They have both been sitting for about an hour now, and on the  pfsense box that cannot connect to its LDAP server, I can no longer make changes to the LDAP server - it shows that it takes the changes, I hit save, go back in, and the object hasn't changed.

    I deleted the object, it showed up as gone, even when I left the screen and came back.  I attempted to re-create it, and got an error that the object already exists - which it did when I went back to the Servers screen in User Manager.  I have tired this in two browsers - Chrome and Firefox.  Firefox had never logged into this system before.  I have gone to the console and reset the webconfigurator.

    I have compared the lighttpd-breakage.log file ownership, and it is the same on both systems.  I'm not sure what else to look for.  I am not able to reboot the non-functional firewall.  Thanks in advance for your time and help!



  • Apparently waiting 18 hours has fixed this issue for now. Not sure what happened, but every change I make is taking now.