Can't get an ip on my wlan



  • Hello. i have tried to setup my wifi card http://www.pcworld.com/product/pg/1558988155/detail
    It is no problem to connect to the wifi but i wont handle out ip's  :'(

    This is how i have configured it

    wan re1
    lan re0
    wifi ath0
    bridge lan - wifi

    my firrewall rules is set to allow all lan on bridge,lan and wifi.
    But i cant fugire out what i should do to get an ip when i am accessing the wifi









  • Banned

    Why are you bridging this in the first place?



  • to get the two networks on same Lan.
    i have been looking around on some guides and others experiences and they are all bridging the network ?


  • Banned

    @notaduck:

    to get the two networks on same Lan.

    Uhm. Is there actually some reason why this is needed? (Everyone's doing it is not one.) The packets will route just fine between WLAN and LAN without any bridge in place.

    Looking at the screenshots, you just cannot decide what you want to do. WIFI - None/None - no wonder you cannot get any IP there. LAN - Static IPv4. Then bridge - again None/None, yet you assign it as interface?  If you really want to bridge, then you should only assign the bridge to LAN and configure the IP, DHCP and whatnot there. Any bridge member should be None/None. Plus play with the system tunables to move the packet filtering to bridge instead of members.



  • Disable the Bridge0 interface but keep the bridge. You don't need any firewall rules on the bridge in a default configuration.

    Add this rule for DHCP on interface WIFI:

    
    Proto        	Source 		Port 	Destination 		Port
    IPv4 UDP	0.0.0.0 	68 	255.255.255.255 	67
    
    

    It has some drawbacks but is good enough at home. Or listen to doktornotor.



  • thanks for the help until now!
    i tried to connect a scrren to my pfsense system and i am getting these errors every time i apply or change somthing on ath0( wlan)
    http://s21.postimg.org/m6qfqitmu/pfsense.jpg


  • Banned

    Yes. I would strongly suggest to stop bridging wireless and wired.



  • @notaduck:

    i tried to connect a scrren to my pfsense system and i am getting these errors every time i apply or change somthing on ath0( wlan)
    http://s21.postimg.org/m6qfqitmu/pfsense.jpg

    You don't need a monitor for that, it's in the system log too. It's a common error that you'll just have to live with until they fix it in FreeBSD.