PfSense 2.2 squid3 Patch captive portal hatası



  • Merhaba,

    Squid3 Patch captive portal seçeneği ve  Authentication sekmesinde Captive Portal çalıştırıldığında /var/squid/logs/cache.log içeriğinde aşağıdaki hataları alıyorum. /usr/local/lib/libpcre.so.3 içeriğinde mevcut ayrıca php modul listesinde de pcre görünüyor. Bu özelliği kullanıp aynı hataları alan var mı? Çözüm bulabildiniz mi?

    Shared object "libpcre.so.3" not found, required by "php"
    Shared object "libpcre.so.3" not found, required by "php"
    Shared object "libpcre.so.3" not found, required by "php"
    Shared object "libpcre.so.3" not found, required by "php"
    Shared object "libpcre.so.3" not found, required by "php"
    2015/02/09 14:11:24 kid1| WARNING: check_cp #Hlpr0 exited
    FATAL: The check_cp helpers are crashing too rapidly, need help!



  • Merhaba,

    libpcre.so.3 hatası düzelmiş ama hala The check_cp helpers are crashing too rapidly, need help! hatsını verip crash oluyor. Bu özelliği captive portal patch özelliğini kullanan yok mu? captive portal dan giriş yapan kullanıcıların adları squid loglarında görünüyor ve sarg gibi raporlarda gayet işe yarıyor. bu hata ile karşılaşan arkadaşlar ne gibi bir çözüm uyguluyorlar, tabiki kullanılıyorsa.

    Selamlar.



  • sorunun çözümü :

    sorun path ler ile ilgili.

    2.2.2 versiyonunda denedim çalıştı.

    rm /usr/pbi/squid-amd64/bin/check_ip.php
    cp /usr/local/bin/check_ip.php /usr/pbi/squid-amd64/bin/

    ln -s /usr/local/bin/php /usr/pbi/squid-amd64/local/bin/php
    ln -s /usr/local/lib/php /usr/pbi/squid-amd64/local/lib/php
    ln -s /usr/local/etc/php.ini /usr/pbi/squid-amd64/local/etc/php.ini
    ln -s /usr/local/lib/libsqlite3.so.0 /usr/pbi/squid-amd64/local/lib/



  • Geri Bildirim için teşekkürler.