Не работает OpenVPN через прокси (и/или Proxifier)



  • Добрый день! Появилась необходимость запустить клиент OpenVPN на ПК за проски сервером (Small Proxy без аутентификации, работает по IP ACL ).

    Попытка 1.
    В обычный конфиг клиента добавили строку http-proxy ip port. При запуске через ГУИ окно лога просто пустое (значит что-то с конфигом не так). Официальная документация на этот случай говорит  http-proxy ip port. Нифига. Выясняется, что работает Proxifier. Ок.

    Попытка 2. Строку с прокси убрали, пробуем напрямую. Соединение виснет на Link Remote ip. Verb ничего не даёт. В этот момент на самом pfSense никаких движений не зарегистрировано.

    Попытка 3. Отключили Proxifier, добавили обратно строку: окно лога снова пустое вообще.

    Брандмауэры на этом ПК и на ПК прокси вырублены, фаерволы на момент подключения тоже.

    Как жить дальше?



  • @dTinside:

    Добрый день! Появилась необходимость запустить клиент OpenVPN на ПК за проски сервером (Small Proxy без аутентификации, работает по IP ACL ).

    Попытка 1.
    В обычный конфиг клиента добавили строку http-proxy ip port. При запуске через ГУИ окно лога просто пустое (значит что-то с конфигом не так). Официальная документация на этот случай говорит  http-proxy ip port. Нифига. Выясняется, что работает Proxifier. Ок.

    Попытка 2. Строку с прокси убрали, пробуем напрямую. Соединение виснет на Link Remote ip. Verb ничего не даёт. В этот момент на самом pfSense никаких движений не зарегистрировано.

    Попытка 3. Отключили Proxifier, добавили обратно строку: окно лога снова пустое вообще.

    Брандмауэры на этом ПК и на ПК прокси вырублены, фаерволы на момент подключения тоже.

    Как жить дальше?

    В настройках OpenVPN-клиента указан адрес и порт прокси ? И да, через прокси работает только c OpenVPN на TCP.



  • в настройках прописано http-proxy 1.1.1.1 1111
    Кончено же, у меня udp. Буду пробовать с TCP.



  • @dTinside:

    Кончено же, у меня udp. Буду пробовать с TCP.

    Вы не поняли. Он нативно не работает по UDP в режиме с прокси, а не от Вашего желания. Это в документации описано.



  • Огромное спасибо! Через TCP все действительно заработало!



  • Еще в этой же конфигурации (через прокси) обратил внимание на то, что после обрыва соединения туннель не восстанавливается, приходится перезапускать службу. После RTFM добавил в файл конфига```
    keepalive 10 180

    Может, кому-то из начинающих (как я) эта инфа пригодится.