Squid Error 503 / 000



  • Buena Tarde a Todos.

    Quería solicitar su apoyo para saber si me pudieran apoyar o guiar para encontrar una solución a mi problema con squid y paginas web.

    Les platico que cuento con maquinas con proxy manual y unas por wpad, con esto incluyo manejo de reglas y puertos donde cierro toda salida y solo le doy apertura a lo que necesito, el 80 y 443 lo bloqueo y solo les doy salida a estos puertos por el squid.

    El problema persiste en algunas paginas web que se quieren visitar y no las abre, algunas otras paginas las abre pero cuando quiere loguearse o entrar a cierta seccion no las abre.

    Revisando logs manda ya sea el error TCP/MISS_000 o TCP/MISS_503, ya cambie DNS externo del FW, ya que mis maquinas solo tienen al mismo FW como DNS ya que por reglas bloquee cualquier otro dns, les eh permitido todo en squidGuard sin bloquear nada y presentan la misma falla, tambien por el string del wpad añado una linea donde digo que dominio.com salga directo y no por el proxy, pero no se soluciona.

    A la IP de la maquina con el error por medio de FW le doy salida a todo y aun asi no pueden entrar a la pagina web.

    Esto pensaría podría ser problema de DNS del proveedor de Internet, pero lo valide quitandole el proxy manual o haciendo que no le mande el wpad a la maquina y asi si pudo entrar a la pagina web, parece que el problema se presenta cuando la maquina solo esta proxyada ya sea manualmente o por wpad.

    Les comento que ya probe con las ultimas versiones de squid2 y squid3.

    Ojala puedan apoyarme a saber si hay algo que me falte o estoy haciendo mal.

    Les agradezco su apoyo.



  • tcp_miss no es un error. Significa que el contenido de la página no fue encontrado en el caché, y lo va a buscar a la página web.

    http://wiki.squid-cache.org/SquidFaq/SquidLogs#Squid_result_code

    hay qué ver qué páginas te dan problemas y crear excepciones en los navegadores ya que tu proxy es no transparente, y luego también en el firewall, ya que algunas páginas (como bien me explicó el sr. Bellera en otro post) no permiten su navegación a través de proxy

    suerte



  • Hola!
    Si utilizas Squid 3 tienes que fijarte en esto:

    dns_v4_first on

    Saludos.



  • Muchas Gracia por sus comentarios.

    Voy a aplicar y revisar sus comentarios a ver si tengo resultados positivos.

    Muchas Gracias!!!!