Asymmetric speeds on symmetrical Internet connection



  • We have a 100Mbps (up and down) Internet connection. When I run our ISP's speedtest from behind pfSense, I get about 80Mbps down and 16Mbps up. We're running Snort, so I tried shutting Snort down and running the test again, but that had no effect. Finally, I moved the test machine onto our external network segment, and ran the same test, one more time. This time, I got about 80Mbps in both directions.

    I'm running pfSense on fairly powerful physical hardware (not a VMware instance), and I have no traffic shaping rules. I've also checked the interfaces for errors (none) and speed/duplex mismatches (none).

    What else can I try to help me debug this problem?



  • Did you check system activity to see if there's high cpu usage or high interrupts?



  • Oops, sorry I forgot to include that. According to "top", I get 0.3%system and 1.7% interrupt on the downstream test. On the upstream test, I get 0.1% system and 0.5% interrupt. User and nice are 0.0 for both tests.



  • Low CPU/interrupt and low performance. The only other thing I can think of is if you enabled something like SYN proxy. Other than that, I think I got the easy question out of the way.

    Anyone else have ideas?


  • Netgate

    Back up the config, reset to defaults, and measure again.  He has something hosed up somewhere.



  • Okay, clearly, I'm an idiot. I thought the tree on the "Traffic Shaper" page was the default setup, i.e. it couldn't be removed. Today, I noticed the GIGANTIC "Remove Shaper" BUTTON. (Arrrggghhh.) When I clicked it (deleting the shaper), and retested the connection, my upload speed hit 75Mbps. Finally, I went through one of the Traffic Shaper wizards, again, used mostly default settings, and retested one more time. Everything is fine, now.

    Sorry for wasting everyone's time. Thanks for your help.