No DNS in virtualbox install



  • I installed pfsense in virtualbox (Win8.1 host). I am using it to learn how it works before I implement it for my actual home network. (and kill the internet while I learn it)

    The host has a single NIC. Pfsense is bridged to it for WAN. I have a second virtual nic attached to the virtualbox nat network. That is set to LAN.

    I have a xubuntu vm which is only attached to the nat network.

    I did the very basic setup of pfsense.  From the xubuntu vm, it is getting an IP from pfsense. It can ping my actual verizon router through pfsense. It can ping other hosts on the WAN side of pfsense (inside my home network).

    I can ping 8.8.8.8 and get a response. However, using a web browser gets me nothing. I have played with all of the DNS settings and cannot seem to get it to do more than ping through pfsense.

    Any suggestions?


  • LAYER 8 Global Moderator

    Well you playing with dns settings tells us nothing.  Are you using the resolver or forwarder?  If your having your clients use 8.8.8.8 do you have dns (tcp/udp 53) open outbound from the client to the internet?



  • I tried with both the resolver and the forwarder. DNS was open outbound.

    However, it appears to have been something with virtualbox I assume. I brought it up this morning to work on it again, and everything was functional without changing anything. Maybe an issue with the host needing a reboot?

    ???



  • you can try to go to setup wizard and tick on allow DHCP dns also put in the primary DNS your DNS or put 8.8.8.8

    Thanks
    Ali Chouman


Log in to reply