Captive portal on zone 0 possible?



  • So I checked out https://doc.pfsense.org/index.php/2.2_New_Features_and_Changes#Captive_Portal and found that the port for the Captive Portal is made up of a zone id (now). Instead of port 8000 as before the captive portal redirects to a page on port 8002 now (in my 2.2 installation).

    Why is my default zone ID 2? And why is it not ID 0 for instance? Where does the zone ID come from anyway? I don’t seem to be able to enter this ID anywhere in the configuration, right?

    For sake of user’s saved login credentials I would prefer to have my single existing zone use ID 0 so the login page is still to be found on port 8000 as before. Is this possible, if so how?

    Thank you!

    -flo-


  • Banned

    No. No such thing implemented.



  • @-flo-:

    …..
    For sake of user’s saved login credentials I would prefer to have my single existing zone use ID 0 so the login page is still to be found on port 8000 as before. Is this possible, if so how?

    "Login credentials" are not related to "using port x to authenticate" - "what is the zone ID (because many can exist)".
    So, in case of doubt, just wipe all portal settings.
    (go even to ssh, start viconfig - wipe everything between <captiveportal>and</captiveportal> , save back, reboot pfsense and set up portal up again.
    (or export config - edit file with good editor like notepad++, and import back in - and then setup your portal again.)

    The fact that it uses a port like 8001, or 8002 (https) or whatever is just a "behind the screen pfSense" thing.


Log in to reply