Router blocking Samba share access through OpenVPN



  • I have recently upgraded my pfSense router to 2.2-RELEASE (latest version) and am now unable to access Samba shares when connected via OpenVPN.  The scenario is that I vpn in to the OpenVPN server (192.168.2.20).  The OpenVPN server assigns me an address of 192.168.3.xxFrom there I used to be able to access Samba shares from another server at 192.168.2.22.  What I'm now seeing in the router firewall logs is that ports 139 and 445 are being blocked from that server.  I'm fairly certain that my OpenVPN and Samba configurations are ok as this used to work before the router upgrade.  I'm guessing the fix is to create some firewall rules but I've tried various configurations and nothing has worked so far.  Can someone point me in the right direction?


  • LAYER 8 Global Moderator

    So pfsense is your openvpn endpont, ie your server or its something behind pfsense.  How do you vpn to something on a rfc1918 address?  Are you local to this network?

    I vpn to my home network all the time and access shares all the time.  I vpn to pfsense public IP, it gives me a 10.0.8.x address, I then access shares of pfsense lan 192.168.1.0/24 network.



  • Rebel Alliance Developer Netgate

    Show screenshots of the firewall log entries that contain the blocked traffic along with screenshots of the rules you tried to make and where they were made.

    Without at least that much it's impossible to speculate about the cause or fix.


Log in to reply