Thank God another one on the same boat with non working Ath0 pci card on AP mode



  • Hi boys n gals its all good right a litle bit of challenge its all good for common sense hehehehheheheheh

    Ok so here we go…...first things first as the topic title mentions.. working but not good, or that means not working??? who knows heheh..

    hardware specs:

    old P4 2.4GH intel cpu + motherboar ASUS P800xxx model  + 2GB RAM + 80GB hdd (that seems perfectly about right for a good setup with old machine.

    3 PCI lan cards ( WAN1, WAN2, LAN DHCP server)
    1 PCI Ath0 wireless atheros card which i want it to be used as AP for access internet on the wireless devices..

    so installed Pfsense 2.0 via USB stick onto the hdd, and boots fine on PFsense2.0 (unfortunatelly cannot say the same about pfsense2.2 it installs 100% on the machine, but the machine simply wont boot at all after install , it allways gets stuck on  Bootmenu F1 selected , but nothing happens.. who knows right????) anyways moving forward.

    after installing 2.0 version its time for some tests, DHCP wan works great on my bridged CABLE MODEM good at least some positive thinking right this is going to work sun do not fear, do not worrie.

    so its about time to setup the lan which i did with dhcp server, and voila my pc just connected via the switch and dhcp was enabled straigh of and working. So as expected i connected to the webinterface and enabled some security features.

    after that i tought well i have the upgrade version just poping up on my dashboard screen why not give it a try right??? yeahhhh lets do it, so auto update invoked and everything went smooth spot on, machine rebooted on 100% with version 2.2 pfsense now installed, great (so still wondering why the USB stick install failed to boot afterwords from the C drive HDD who knows. maybe we will simply never know..

    ok so i tought now finally its timeeeeeeeeeeeeeeeee, on the blue corner the silver weight medalist champion bla bla.... oppppsss shite sorry its not UFC time yet.. lets get back on track.

    So here we go, i am looking at my wiriless card and thinking i guess this is it, its about time right.

    but wait i simply do not want it to be shared on dhcp like someone mentioned cause i just want it to surf the web and not give permission to access my work servers , great so what to do next?

    solution, created a new IPV4 with  dhcp on the ath0 card wireless with different LAN address, so enabled the wireless card to work in Access point mode. for testing ofcourse all wep,wpa security features were disabled..

    selected my country fcc on the list... and enabled the dhcp server ipv4 different lan address for the wireless wlan (note allways choose higher lan sub address for wlan then real LAN wired dhcp server, if you choose lower subnet address it will simply block you out on the real lan , who knows maybe its just me but it actually happened with me lost access to the internet etc.. could not even log into webconfig page of pfsense in local lan, and to my surprise ofcourse my lan ip had been changed to the same WLAN dhcpserver address , maybe its a bug on 2.2 not sure)

    so my setting up my lan to 192.168.10.1 gateway and my wlan to 192.168.20.1  this works great , my lan keeps working fine and my wlan can now accept logins from wifi clients such as mobile phones or wireles devices in b,g,ng mode... now thats great.. but ???

    yes but.... no internet access , ofcourse its required to create a NAT rule for your new wlan dhcp server to allow him access to the internet, so i went on firewall / rules

    and created a new rule called,  Default allow wlan to any rule, and gave PASS access to the wlan dhcp server to connect on the internet.. great voillá now wifi devices now have access to the internet also but they do not have access to my LAN address  which is also good.

    so i am thinking good sun you have done it once more, big up for you, but somewhere in the background i heard that litle quiet voice saying.. wait dear old boy its not over yet, just make a full reboot for testing purposes and lets just hope everything comes back up in a good working environment order.

    so my adiction to push buttons on the keyboard did not let me win on this one, and i must confess i am guilty as charge , i had to click on the reboot button from the webinterface so i could reboot the system.

    And guess what?????????????????????? nothing ......... actually nothing really happened , appart from the big white screen saying

    ERROR 500 .. and i was like hmm interesting , why did i fckucking clicked the reboot  button right? but hey after all its just testing

    so i tought could be a page issue lets refresh mozilla cache , delete cache etc...

    and voillá  ERROR 500 is now gone, thank God ...................... but wait its not going anywhere, no reboot has been issued on the system and now ERROR 503 Service not available... at this time i tought hmmm.. lets check the console shall we.

    So good back on the console  , press 5 reboot system, and system rebooted fine.. so now i have  webif access again, but noo... wait whats that litle icon on my network card from the pc telling me there is not internet connecting, this can´t be true i cannot believe it.

    So lets check the WAN interface, so yes no IP obtained.. but all conections are ok, lets just press save again to save same config on the interface WAN shall we?

    ok done , great now i have IP and DHCP new IP from ISP cable provider has been obtained, now my wifi access working, and my LAN internet access also working.

    So lets check the dashboard again to check Internet details shall we , so clicked Dashboard link again.......... and ooooooooohhhhhh now ERROR503 service not available... at this time i am like WTF is going on here?  but still internet working fine on wifi AP and LAN. PC devices .. but WEBIF is simply not working, lets check console again...

    and ofcourse new issue , and new error ath0: stuck beacon; resetting (bmiss count4)

    so my wifi card is messing up the system, i entered in console ssh mode and  top -S -H    it shows..  100% IDLE but not on the cpu ...

    so my cpu load is ok, memory ram available still 1500MB

    so i read wait this is a channel broadcast wifi issue, lets try another one as i was using channel 99...  lets try channel1  after rebooting the pc i have webif access and i managed to try channel1, but again after each consecutive reboot, my WAN dhcp  stops working if like new configuration was being overwritten by something else, and each time i have to go on WAN and save same dhcps setting again and , after that i loose access to webif again allways giving me error 503,  and the ath0 stuck beacon error..

    so i took few hours and tested everysingle channel from 1 to 99 , and guess what the same error on all of them happens..
    so i tought well lets just make some factory reset default, so i done it via console .

    and just enabled the 3 LAN cards,  WAN1, WAN2, LAN ( now works great, DHCP on WAN1  and PPOE on WAN2 work great no erros, pick up ip straigh on, and dhcp lan working fine also, no more ERROR 503...

    So like many many others on the forum i come to ask the same old funny question is really WIFI working for good or its a ongoing trial project?

    i know there is a solution (just disable wifi  card) but appart from that easy hack around the situation any other odd option i could try out?

    eventually if i find the solution one day i will post it for all


  • Banned

    Not interested in reading the above incoherent tirades incl. installing pfSense 2.0 (WTF?!?). You did not even bother to post the exact wifi card model AFAICT (yet another WTF.)

    If you are having trouble with the wireless, get the latest 2.2.1 snapshot from here (which includes ath wifi drivers from FreeBSD 11-CURRENT) and test: http://snapshots.pfsense.org/FreeBSD_releng/10.1/i386/pfSense_RELENG_2_2/updates/ - messing with unsupported ages old versions is a blatantly obvious waste of time.



  • Yeah, the post made me kind of dizzy. Wireless is known to be problematic at n speeds under 2.2, so as our good doktor suggested, use one of the 2.2.1 dev snaps that has newer wireless drivers. In addition check the following:
    Don't use 'auto' channel.
    Set the regulatory settings.
    (Think you got those two)
    Change key rotation to 300
    Use WPA2 with wme enabled.



  • hiya

    sharp replies heheh, well i am runnign 2.2 from update it says i am now on the current update version..

    so heres the update outcome.. reset all to factory default..

    disabled wifi..

    configured all up again. then enabled otp2 wifi AP via webinterface and i set it up to new ipv4 dhcp lan address…

    then rebooted. and all up working normal now.. no more beacon stuck error messages.. believe it or not using same exact config i posted earlier.. now as for my WAN i cannot say the same still not comming up on DHCP something wrong. even do its enabled DHCP and modem is on BRIDGE mode completelly it should update the IP automatically.

    but its not i have to enter on the wan interface, disable it, then save, then enabled it then save.. and it updates the IP from ISP

    as for the working set i will post the pictures here to make this AP atheros wifi working still no encryption used at all, so will start playing with the encryption mode now

    also created a rule on the  Firewall, Rules,  for the WIFI wlan, to allow all tcp access to internet on the wlan

    ![wifi rule.jpg](/public/imported_attachments/1/wifi rule.jpg)
    ![wifi rule.jpg_thumb](/public/imported_attachments/1/wifi rule.jpg_thumb)



  • The stuck beacon driver issue is something that appears, from our testing thus far, to be resolved with the driver in 2.2.1. That's what you should be on right now for any new wireless deployments with 11n. They're development snapshots and not yet an official stable release, but everything wireless has tested out much better on 2.2.1 than anything prior, and things overall are stable in snapshots at the moment.



  • @cmb:

    The stuck beacon driver issue is something that appears, from our testing thus far, to be resolved with the driver in 2.2.1.

    I'm sorry to report that I've had a stuck beacon three times with an AR9280 since I upgraded 14 hours ago. That being said, even 2.2.0 worked fine for me as a home AP.



  • @pLu:

    I'm sorry to report that I've had a stuck beacon three times with an AR9280 since I upgraded 14 hours ago.

    The messages still come up on occasion, that much is normal at times. The situations where you end up with a flood of stuck beacon logs and a non-functional AP shouldn't be an issue.

    @pLu:

    That being said, even 2.2.0 worked fine for me as a home AP.

    what kind of config are you running with it? There are still some outstanding issues that I'm working on tracking down, knowing what works for you would help.



  • @cmb:

    @pLu:

    That being said, even 2.2.0 worked fine for me as a home AP.

    what kind of config are you running with it? There are still some outstanding issues that I'm working on tracking down, knowing what works for you would help.

    
     <interfaces><opt2><if>ath0</if>
    		 <wireless><mode>hostap</mode>
    			<standard>11na</standard>
    			<protmode>off</protmode>
    			<ssid>Indeed</ssid>
    			<channel>64</channel>
    			 <authmode><txpower>99</txpower>
    			 <distance><regdomain>etsi</regdomain>
    			<regcountry>SE</regcountry>
    			<reglocation>indoor</reglocation>
    			 <wpa><macaddr_acl><auth_algs>1</auth_algs>
    				<wpa_mode>2</wpa_mode>
    				<wpa_key_mgmt>WPA-PSK</wpa_key_mgmt>
    				<wpa_pairwise>CCMP</wpa_pairwise>
    				<wpa_group_rekey>60</wpa_group_rekey>
    				<wpa_gmk_rekey>3600</wpa_gmk_rekey>
    				<passphrase>yes</passphrase>
    				 <ext_wpa_sw><enable></enable></ext_wpa_sw></macaddr_acl></wpa> 
    			 <auth_server_addr><auth_server_port><auth_server_shared_secret><auth_server_addr2><auth_server_port2><auth_server_shared_secret2><wme><enable></enable></wme> 
    			 <pureg><enable></enable></pureg> 
    			 <apbridge><enable></enable></apbridge> 
    			 <puren><enable></enable></puren></auth_server_shared_secret2></auth_server_port2></auth_server_addr2></auth_server_shared_secret></auth_server_port></auth_server_addr></distance></authmode></wireless> 
    
    		 <spoofmac><enable></enable></spoofmac></opt2></interfaces> 
    
    

    I noticed with 2.2.0 that standard 11na and channel auto gave me an 11ng 2.4GHz channel. Haven't tried it again with 2.2.1.

    Edit: Hardware checksum offload doesn't work with Atheros AR9280 (at least not on 2.2.0). Packets will get dropped.



  • @pLu:

    I noticed with 2.2.0 that standard 11na and channel auto gave me an 11ng 2.4GHz channel. Haven't tried it again with 2.2.1.

    There is brokenness in auto channel selection, which is why 2.2.1 makes you pick a specific channel for host AP (and enforces picking a specific channel proper for the standard chosen). Otherwise it just picks whatever it wants, and seems to get stuck on 11b at times if it chooses anything. We have a couple FreeBSD bug reports open on that, though 2.2.1 is capable of working around those issues (and actually forces you to do so with input validation).

    @pLu:

    Edit: Hardware checksum offload doesn't work with Atheros AR9280 (at least not on 2.2.0). Packets will get dropped.

    Hm, I've kept that enabled on all my 2.2.1 testing and haven't seen it be a problem and I have mostly 9280s. So that might be specific to the ath(4) in stock FreeBSD 10.1.



  • @cmb:

    @pLu:

    Edit: Hardware checksum offload doesn't work with Atheros AR9280 (at least not on 2.2.0). Packets will get dropped.

    Hm, I've kept that enabled on all my 2.2.1 testing and haven't seen it be a problem and I have mostly 9280s. So that might be specific to the ath(4) in stock FreeBSD 10.1.

    As soon as I uncheck "Disable hardware checksum offload" and click Save on 2.2.1, too, I lose 'connection' because the returning packets have a zero checksum (I didn't reboot). I have an APU with the Compex WLE200NX.

    From tcpdump -v -i wlan0 on my Linux laptop:

    
    08:07:51.650544 IP (tos 0x0, ttl 64, id 13111, offset 0, flags [none], proto UDP (17), length 160, bad cksum 0 (->c53d)!)
        192.168.0.1.domain > 192.168.0.135.6921: 53023 NXDomain 0/1/0 (132)
    
    


  • hi guys

    back again ok so did some tests few days ago with the development version .. but my new firewall is x64 anyways so i updated it again today to 2.2.1

    wifi now works i have set up a wlan address different from my lan address and allowed it to surf the web so far so good..

    my only issue now is..

    none of the wifi devices can get ip via DHCP  i need to put fix static ip setup on my wifi on my notebook, also my iphone detects the ssid network name but cannot connect using DHCP settings i need to configure connection manualy with fix ip to work …

    am i missing something??

    I am using Static IPV4

    Ipv4 address  192.168.xxx.1  /24

    or do i need to enter the console config menu of pfsense and configure IP interfaces via console menu? cause on the LAN Ip port it asked me if i wanted to enabled DHCP for this LAN

    but on the wifi i have configured via the WEBIF...


  • LAYER 8 Netgate

    Services > DHCP Server

    Make a DHCP server for your interface.



  • @Derelict:

    Services > DHCP Server

    Make a DHCP server for your interface.

    Hi

    yes i eventually after typing my first message had the Console window of the server open on the screen also and configured the IP address via console menu and enabled DHCP there. now its all working also..

    with dhcp


Log in to reply