I can not from 2.1.5 to 2.2.1



  • i always can not normal install from 2.1.5 to v2.2.x. could you help tell how i  do fix it ?


  • Banned

    Not with this amount of information, no….



  • plese see photo.




  • At what point are you seeing that? Booting off ISO, or memstick, or after installing, or…?



  • i am from pf2.1.5 web firwm upload the v2.2.1 amd64 full update file for install.



  • what hardware?

    Looks like the disk is disappearing, which could be the disk actually dying, or some behavior change with the hardware you're using.



  • So buy a new disk, install pfsense then restore old configuration?



  • @cmb:

    what hardware?

    Looks like the disk is disappearing, which could be the disk actually dying, or some behavior change with the hardware you're using.

    I think hardware no problem. only PFv2.2 not support v2.1.x config file.  I  try new install with cd ISO file just install is ok.

    but pf 2.2.x still can not restore old version pf 2.1 config file. now I have to back to the pf 2.1.5.

    please tell how use old v2.1.5 config file in pf 2.2 ?


  • Netgate Administrator

    2.2.X can use any earlier config file. The scripts to read it and translate it to the newer config file version are all included.
    https://doc.pfsense.org/index.php/PfSense_and_FreeBSD_Versions

    There are various factors to take into account upgarding to 2.2, did you read this?:
    https://doc.pfsense.org/index.php/UpgradeGuide#pfSense_2.2_Upgrade_Notes

    What hardware are using exactly?

    Steve



  • @yon:

    please tell how use old v2.1.5 config file in pf 2.2 ?

    In virtually all circumstances, just restore it and go.

    If you get disk errors of the like you were seeing just by restoring a config, you had something unusual set in there, probably under System Tunables. Maybe your hardware needed some setting set to a non-default for some reason in earlier versions, but should now only use the default. Check what you had set in tunables, if it's the same disk error, it's almost certainly something there.



  • why pf2.1.5 is working. pf 2.2.x not.

    I will offer about hardware informations more later.

    ![PF2.1.5 - Status Dashboard.png_thumb](/public/imported_attachments/1/PF2.1.5 - Status Dashboard.png_thumb)
    ![PF2.1.5 - Status Dashboard.png](/public/imported_attachments/1/PF2.1.5 - Status Dashboard.png)



  • IDE 80GB Disk …




  • I try chang the disk to SATA 500GB DISK WITH AHCI start in PFv2.2.1, but it use restore pf2.15confing file after, PF2.2.1 system auto reboot to vlan setup item. pf2.2.1 still not normal work.




  • Can you go to Diagnostics > smart status > in the info section, select all - Then press view.  Can you past the output here?

    Assuming this rig is SMART capable.



  • @kejianshi:

    Can you go to Diagnostics > smart status > in the info section, select all - Then press view.  Can you past the output here?

    Assuming this rig is SMART capable.

    this is working PF2.1.5 with IDE DISK 80GB

    ![PF2.1.5 - Diagnostics S.M.A.R.T. Monitor Tools.png](/public/imported_attachments/1/PF2.1.5 - Diagnostics S.M.A.R.T. Monitor Tools.png)
    ![PF2.1.5 - Diagnostics S.M.A.R.T. Monitor Tools.png_thumb](/public/imported_attachments/1/PF2.1.5 - Diagnostics S.M.A.R.T. Monitor Tools.png_thumb)



  • Can you check your bios and enable SMART if its an option.  Currently its either missing or turned off.

    After that, try to view the smart info and paste here again.  Thanks.



  • my bois have no this option. where find it ?





  • Netgate Administrator

    The fact that it's dropped you at the assign interfaces screen means that one of your interfaces detected in 2.1.5 is no longer detected for some reason. What interfaces do you have defined in 2.1.5?

    I see you have a run(4) interface. Remove that before upgrading to 2.2. At this time at least some run devices seem to cause a kernel panic in 2.2. The one I have here does.

    Steve



  • To turn on smart, you will have to look inside each one of those menus there and find smart.  Turn it on and save.  As for the run(4) issue, if thats a freebsd issue, you may be just screwed.



  • @kejianshi:

    To turn on smart, you will have to look inside each one of those menus there and find smart.  Turn it on and save.  As for the run(4) issue, if thats a freebsd issue, you may be just screwed.

    i have no find the smart option.



  • @stephenw10:

    The fact that it's dropped you at the assign interfaces screen means that one of your interfaces detected in 2.1.5 is no longer detected for some reason. What interfaces do you have defined in 2.1.5?

    I see you have a run(4) interface. Remove that before upgrading to 2.2. At this time at least some run devices seem to cause a kernel panic in 2.2. The one I have here does.

    Steve

    I will try remove interface in pf2.1.5



  • @stephenw10:

    The fact that it's dropped you at the assign interfaces screen means that one of your interfaces detected in 2.1.5 is no longer detected for some reason. What interfaces do you have defined in 2.1.5?

    I see you have a run(4) interface. Remove that before upgrading to 2.2. At this time at least some run devices seem to cause a kernel panic in 2.2. The one I have here does.

    Steve

    your are right.  it is becasue not using  interface has no remove.  just upgrad to PF2.2.1

    but the pf2.2.x  ipv6 not normal work. just ipv6 gateway show online, but LAN ipv6 can not go to internet.  The DHCPV6 not normal work.

    ![pf2.2.1 ipv6 - Status Dashboard.png](/public/imported_attachments/1/pf2.2.1 ipv6 - Status Dashboard.png)
    ![pf2.2.1 ipv6 - Status Dashboard.png_thumb](/public/imported_attachments/1/pf2.2.1 ipv6 - Status Dashboard.png_thumb)


  • Netgate Administrator

    You will need to be more specific. IPv6 is not broken as far as I know in 2.2.1 snaps.

    Steve



  • @stephenw10:

    I see you have a run(4) interface. Remove that before upgrading to 2.2. At this time at least some run devices seem to cause a kernel panic in 2.2. The one I have here does.

    Just FYI, run(4) should be fixed in the next snapshot:
    https://redmine.pfsense.org/issues/4117#change-17648


  • Netgate Administrator

    Yep, I tested it this morning and it worked fine.

    Steve



  • run(away)


Log in to reply