Can't Connect To WebGUI Via Firefox (Works In IE)



  • Hi all,

    I'm having a problem connecting to the WebGUI's of various pfSense's through Firefox.

    It's not a rules thing - I can connect via IE on the same PC. When I've had the issue before, a reset of my Firefox profile has sorted it…. for a period!

    I'm accessing all the pfSense's using the URL - https://ip:11443 - which as I say, works on IE.

    On Firefox, I get either a couple of minutes wait before getting to the login screen, or it'll time out saying "the connection was reset".

    It's not a mega-issue as I could use IE, but it's annoying - and repeatedly resetting Firefox profile is a pain as there's a bunch of other stuff I have to set back up too.

    Currently Firefox has NO addons installed. I've also tried deleting the manually added certificates for all the pfSenses.

    Any ideas?! And thanks in advance :-)



  • Sounds  like Firefox might be proxied. Check the proxy settings and see if it's pointing to a proxy server - if it is and IE isn't, then that may be your answer.



  • Do you have LastPass installed?

    I've found I cannot connect at all (multiple OSes, pfSense boxes, versions, etc) if it is installed.  Firefox without LastPass works perfectly so I just keep a Firefox profile that doesn't have it installed.


  • LAYER 8 Global Moderator

    What??  Sounds more like you have last pass messed up sending the wrong creds to me.. I have no issue access pfsense web gui with firefox 37.0.2 with lastpass as well - its what logs me in..

    Last pass is NOT the problem - if you think it is just disable it so it doesn't send login creds, etc.


  • Rebel Alliance Developer Netgate

    If the certificates were generated before 2.2, you're probably hitting a Firefox bug with how it handled our old default certs.

    https://bugzilla.mozilla.org/show_bug.cgi?id=1056341

    You can manually clear out any of the old/bad certs, it might let you into ~8 of them before it craps out again.

    If you are on 2.2 on these boxes, go to a shell and run:

    pfSsh.php playback generateguicert
    

    And then it'll make a new cert that will make Firefox happy.



  • jimp, that worked for me… thanks


Log in to reply