Squidguard Blacklist wird nicht komplett übernommen



  • Hallo,
    habe nun alles auf einer SSD und jetzt klapps auch mit squidguard…
    Habe als Blacklist: http://www.shallalist.de/Downloads/shallalist.tar.gz

    Heruntergeladen, 74 Kategorien. Unter Common ACL die Rules definiert und gespeichert, auf Generel Setting gegangen und Apply gedrückt.
    Dann kamen die Fehlermeldung dass ca. 25 Kategorieverzeichnisse nicht gefunden wurden. Im Filemanager nachgesehen und tatsächlich, die Kategorien fehlen.

    Hier eine Beispielsfehlermeldung:
    (B1) BLACKLIST 'blk_BL_recreation_martialarts' error: file '/var/db/squidGuard/blk_BL_recreation_martialarts' not found

    Wo liegt das Problem?
    Speicher müsste ich massig haben bei 16GB SSD
    Kann man die fehlenden Verzeichnisse hochladen? Als Bulk?

    Gruß Andreas



  • Hallo Andreas,

    das Problem hatte ich auch. Sieh Dir mal auf dem Dashboard die Disk-Usage an. Läuft der variable Speicher voll?
    Falls das so ist, kannst Du den variablen Speicher vergrößern und dann die Liste neu laden.
    Leider suche ich selber nach einer Lösung, wie man die Blacklist auf die Speicherkarte schieben kann.

    Viele Grüße
    Matze



  • Hi,
    wie hoch hast du denn die beiden Werte gesetzt? Ich habe sie jetzt vom Standard eben mal verdoppelt auf 80/120MB

    Andreas



  • OK, das funktioniert jetzt,
    aber es wird nichts gefiltert obwohl beide Service laufen und ich in der target rule list alles als deny markiert habe.
    Habe Squid so konfiguriert:

    • Interface: Lan, Lan2, WLan

    • Allow Users on Interface: ja

    • Transparent Proxy: ja

    • Enable Logging: ja

    • Log store directory: /var/squid/logs

    • Proxy Port: 3128

    • Whitespace: strip

    • Custom Options (vom Squidguard eingetragen):url_rewrite_program /usr/pbi/squidguard-amd64/bin/squidGuard -c /usr/pbi/squidguard-amd64/etc/squidGuard/squidGuard.conf;url_rewrite_bypass off;url_rewrite_children 16 startup=8 idle=4 concurrency=0

    Konfiguration Squidguard:

    • LDAP: nein

    • enable Log: ja

    • Blacklist: ja (shallalist)

    • TargetRules: gesetzt auf deny

    • SafeSearch: ja

    In der Filterconfig steht unten am Ende folgendes:

    acl  {

    default  {
    pass !blk_BL_adv !blk_BL_aggressive !blk_BL_anonvpn !blk_BL_dating !blk_BL_downloads !blk_BL_drugs !blk_BL_dynamic !blk_BL_finance_banking !blk_BL_finance_insurance !blk_BL_finance_moneylending !blk_BL_finance_other !blk_BL_finance_realestate !blk_BL_finance_trading !blk_BL_fortunetelling !blk_BL_forum !blk_BL_gamble

    Wenn ich richtig sehe steht dort pass!
    Aber das würde doch bedeutet dass alles durchgelassen wird?

    Andreas



  • Das "!" ist in der Regel ein "NOT" … also "pass NOT blahblah"
    Oder lieg ich da falsch?


Log in to reply