Routing zw. 2 priv. Netzen



  • Hi,

    ich versuche gerade einen pfsense für das Routing von 2 privaten Netzen zu verwenden. Es geht um folgende Netze:
    1. 10.137.137.x /24 -> LAN
    2. 10.11.0.x /30 GW: 10.11.0.97  -> WAN

    Ich habe den pfsense also auf der WAN Schnittstelle mit statischer IP konfiguriert: 10.11.0.98 und habe einen Gateway mit der 10.11.0.97 konfiguriert.
    "Packet filtering" und "Outbound NAT" habe ich deaktiviert, da er ja nur routen soll. Über den Gateway ist eine öffentliche IP erreichbar und wenn ich vom pfsense aus ein Traceroute mit "Source Address" "LAN" angebe, bekomme ich nur "* * " also er scheint es nicht zu routen. Bei "Source Address" "WAN" schafft er 2 Hops und erhalte dann " * *" da die öffentliche IP nicht pingbar ist.
    Muss ich sonst noch eine Einstellung machen, damit der pfsense die 2 privaten Netze routet ?
    Setze den pfsense 2.2 Release ein.

    Habt ihr mir noch Tipps ?



  • Hallo,

    ohne ONAT verlässt ein Paket von einem LAN-Host mit seiner LAN-Adresse die pfSense auf der WAN-Seite Richtung Default Gateway. Das kennt aber vermutlich dein LAN-Netz nicht, d.h. wenn ein Paket, mit Ziel-IP in deinem LAN zurückkommt, wird es verworfen, weil Ziel unbekannt.

    2 mögliche Lösungen:

    • NAT einschalten. Dann erhält das Paket vom Outbound NAT die WAN-IP, die auch das Gateway kennt.

    • Am Gateway eine statische Route für das LAN mit Ziel WAN-IP einrichten.

    Grüße



  • Hi,

    habe beide deiner Möglichkeiten getestet, aber leider keine Ändrung.
    Hier die Routingtable:

    default                 10.11.0.97    UGS 45     1500   rl1
    10.11.0.96/30  link#2 U 72328 1500 rl1
    10.11.0.98         link#2 UHS 0 16384 lo0
    10.137.137.0/24 link#1 U 103884 1500 rl0
    10.137.137.90 link#1 UHS 0 16384 lo0
    91.106.121.3/32 10.11.0.97 UGS 27 1500 rl1
    127.0.0.1         link#7 UH 25216 16384 lo0

    Sieht doch eigentlich gut aus oder nicht ?  :-\



  • Auf dem WAN-Interface, den Haken bei….

    Block private networks
    

    …hast Du raus und als Gateway steht da....

    10.11.0.97
    

    …drin.?



  • Ja den Haken bei "Block private networks" habe ich entfernt und bei IPv4 Upstream Gateway habe ich den 10.11.0.97 ausgewählt.



  • Ich sehe gerade in den Logs bei Routing folgende Fehler:

    Mar 7 12:53:23 radvd[24644]: sendmsg: Permission denied
    Mar 7 12:53:19 radvd[24644]: sendmsg: Permission denied
    Mar 7 12:53:12 radvd[24644]: sendmsg: Permission denied

    Was hat dies zu bedeten ? Kann es daran liegen, dass das Routing nicht klappt ?  :-\


Log in to reply