Wireless bridging and OS X bonjour odd behavior



  • Hi-

    I was wondering if anyone else has experienced this problem. I'm running pfsense on a pc engines alix board with an onboard minipci wifi card. I have my ath0 interface bridged to my LAN interface and this works well most of the time. After the pfsense box is up for some period of time, usually a little more than a day, I can no longer ping addresses via the bonjour service. For example, after a recent reboot I can ping mywiredmachost.local from mywirelessmachost.local, but after a day or so I can no longer ping it and my bonjour services stop working. Rebooting the pfsense box fixes this for a day or so.

    Another problem I've been experiencing is that on mywireless mac I run a vmware windows instance with the network bridged onto the wireless interface of the host mac. Also after a day or so, I can no longer renew my dhcp address in the virtual machine. Once again, rebooting pfsense fixes it.

    Ideas?

    Thanks-



  • Anyone find an answer to this?  I am experiencing the exact same behavior.



  • This is normal behavior for Bonjour. Bonjour uses a multicast address for each connected interface, local to that interface. It won't be pass ed through the bridge. What you need is a reflector for bonjour to broadcast mDNS info. Avahi is just that reflector. I couldn't install it via the package manager as of 1.2.3rc2 on tinybsd but a manual install worked fine. I used the tutorial here
    http://www.ucsecurity.com/article/2008/12/29/avahi-on-pfsense/

    The added plus is now my pfsense box shows up as a device in bonjour for one click ssh and webgui, very cool.

    As a final resort, you could just map the addresses in dns, but thats work.


Log in to reply