Rt3072 wifi run0 device just crashes



  • I have posted about this problem before.  I am NOT trying to use this usb adapter for an AP, just using it for the WAN, and it never works, pfsense just crashes immediately when I select run0 and hit save.  I finally managed to get a crash dump, if anyone knows something please let me know, my next step would be to submit this as a bug.

    pf-crash.txt



  • I think the run patch we imported into 2.2.1 only fixed a crash with hostap, but I would definitely recommend trying with 2.2.1. Release coming tomorrow, latest snapshot at snapshots.pfsense.org is very nearly the same as release.



  • Thanks, but I tried just yesterday using:  pfSense-Full-Update-2.2.1-DEVELOPMENT-i386-20150313-0430.tgz

    And it crashes.  Is there something better I should be using?



  • That should be the same in that regard, but give it another shot with release and let us know how it goes. In this case, make sure you reconfigure it with 2.2.1 on there, don't just restore a config from a previous version with the wireless already setup. There is now input validation there to prevent a number of invalid combinations of options (like trying 802.11g with a 5 GHz channel, for instance), which could potentially prevent a problem config.



  • hi, thanks for the reply.  I have tested this like you said completely fresh install, but the result is exactly the same.  The problem always happens when I save the interface settings.  I even added OPT1 and assigned run0 to it, and it saved fine, but when I edit OPT1 with even the most basic settings, pfsense crashes.  It used to work with 2.2-BETA (i386) built on Mon Oct 27 15:33:34 CDT 2014, not long after that the problem was introduced.

    pf2-crash.txt



  • What exactly is the config you're trying to use on it? I've been testing with a run card the last few days as a client with WPA2 and it's been solid.



  • Though one important difference came to mind. The mode selection might be causing problems for you, and is a potentially significant difference between 2.2.1 and what I'm running.

    I'm running on mode "auto", which wasn't added until post-2.2.1 release. If you gitsync to RELENG_2_2, your "Standard" drop down will have an "auto" selection.
    https://doc.pfsense.org/index.php/Updating_pfSense_code_between_snapshots

    Choosing "auto" for Standard might fix what you're seeing there.



  • I'm also having issues with run0 on multiple cards. RT3070 and RT3572/RT3052

    So I just stupidly spent money on a Linksys card, ASUS card and TP-Link. I'm also trying the ALFA cards with no luck either.

    I researched them all to make sure they had the correct chipset that would match the drivers on pfsense.

    I've got crash reports that should be submitted.

    The same thing is happening to me as OP.

    When I click on SAVE interface and Apply the settings, pfsense crashes, I see it crashing on the console.

    After it crashes, I remove the offending card.

    The console asks me to to re-assign the interfaces to WAN/LAN etc.

    I do that and I can log in to the web admin interface. WAN is still down at this point.

    Once I'm able to log in to the web admin interface, I have to go back into my interfaces and re-assign PPPoE (that's what I'm using) and re-assign it back to the WAN adapter.
    That association disappears after the crash.

    Sometimes I have to reboot after that change or sometimes I don't and the Internet will come back.

    As a side note, the verification window doesn't show up on the MAC OS X versions of Firefox or Safari (latest versions). It does show up in Chrome (luckily)



  • Well, I finally tried updating to the development version as you mentioned, and I saw the "auto" feature you said.  But the result was still the same..

    The only way I can rule out a driver problem is if you know the module had been updated between the release date I mentioned in my OP.  Otherwise it had to be a pfsense change that did it.



  • Hi,
    I want to use AzureWave AW-NU221(RT3072) usb wireless card for access point and I also have this problem.

    I use Pfsense 2.2.4-RELEASE  (i386)  built on Sat Jul 25 19:56:41 CDT 2015 FreeBSD 10.1-RELEASE-p15.

    When  I plug in RT3072 then Pfsense crash.

    I try to reinstall  Pfsense 2.2.4 and I find that if I plug in RT3072 first then the install process will crash.

    I had try another RT3072 usb wireless card and got the same result.

    Because I could use the same hardware to run OPNsense 15.7.17 FreeBSD 10.1-RELEASE-p19 OpenSSL 1.0.2d 9 Jul 2015

    So I believe that Pfsense can be run on it too.

    Are there anyone know what the matter?



  • I saw some similar results recently. FreeBSD worked but pfSense has problems.

    Have you tried the 2.3 Alpha build? It may be better now…



  • Hi,
    I download pfSense-memstick-2.3-ALPHA-i386-20151029-1841 and install it.

    But during the first boot Pfsense crashes.

    I saw the messages on monitor shows :

    Default interfaces not found –- Running interface assignment option.
    Run0 : firmware RT2870 Ver 0.33 loaded.

    And then pfsense crashes.

    I get confuse because I saw this in the OPNsense websit:

    OPNsense® is a fork of pfSense® that in its turn has been forked from m0n0wall®.

    So I believe that Pfsense can use RT3072 without problem but actually not.


  • Banned

    Why people waste time with similar BS goes beyond me. Get yourself an AP with RJ45 plug. It works. Everywhere. (If you insist on sticking some wireless HW into pfSense box, don't bother with anything that's not Atheros-based.)



  • Hi,

    Are you sure that Atheros base has no problem??

    I have tested several atheros base wireless card "AR5BMB5", "AR5BXB63","AR5B95".

    I tested from Pfsense 1.2.3 to 2.2.4, almost every time when Pfsense development team released a new version, I will test again. And all of them have the same problem "ath0: stuck beacon; resetting (bmiss count 4)".

    When the screen shows this messages for servel times then the wireless will loss connect to internet, so I start to look for second solution.

    I found that OPNsense (a fork of pfSense) can use RT3072, so I reply this issue here.

    I hope this information will be help to solve this problem.

    PS. My English is poor but I will try my best.



  • I have found Atheros to be a good card. Especially AR9380 series. AR5BXB112 is the module I recommend. But your beacon problem subsided at version 2.2 for me. Even before it worked fine but the console was loaded with the error messages…
    You are using the 5 ghz Band? Called 802.11NA in pfSense.. Have you done a local survey to see what channels are clear? It can make a big difference instead of fighting your neighbors gear and weakening both signals.



  • Hi, Phishfry

    Thank you!

    I live in the mountains, no neighbors within around 200 meters. When I tested only Pfsene wireless AP is in use.

    My wireless used only 2.4ghz .

    I will try to use different channel and hope it get good result.

    I think it is better return to the subject:rt3072 wifi run0 device just crashes.

    "ath0: stuck beacon; resetting (bmiss count 4)" issue has been raised by Panja in another subject and it is better to discuss there.



  • The trouble i think has to do with a module that is not loading automatically with the run0 firmware.
    wlan_amrr.ko must be hand loaded at boot or kldload on FreeBSD so maybe the problem is there. Quick test is copy the module over and kldload it.
    I have run0 HostAPD running on FreeBSD-armv6 and Nas4Free installs.
    The RT5592 has 2T2R so I am tempted to crack one open and see if I can get an descent antenna on it. It is supposed to be 2.4/5ghz but i am having troubles with 11na mode.



  • The usb stick I am using is actually sold as a RT5572 but shows up in FreeBSD as RT5592

    http://www.ebay.com/itm/291559100340

    It loads the RT3071 rom


  • Banned

    Yeah, beyond the fact that wifi support sucks goats nuts in FreeBSD, one of the generic troubles being that the "same" model is being sold with 10 different chipsets by manufacturers as the time goes.



  • It is just a fun experiment for me. running -ifconfig wlan0 mediaopt ap ssid cornhole mode 11a channel 140- is a blast.
    I am surprised how seemless the cross platform stuff is. Same instructions for any architecture.

    Hostapd on the NAS4Free/Odroid was an interesting concept…2 birds with one stone. Jail kept wiping my setup. I am unfamiliar with their setup.


Log in to reply