All Devices work except Mac

  • Good Day,

    Here's how we have our home setup:

    pfSense router with a TL-WDN4800 card that serves as the AP, 802.11n WPA2

    All our devices can connect to the wireless network served by pfSense; PC, iPads, Android smartphones, including the Apple TV, except my Macbook Pro, which does connect when I boot it into Windows. I'm not sure if it's my setup, or OS X can't seem to get an IP from the DHCP server.

    When I test with a D-Link router (DSL-2750U), the mac can successfully connect to the Wi-Fi network.

    Any ideas where I might've gone wrong?

  • I your Selected wifi Channel above 11 ? if so change it to 6 and test again

  • This is going to sound crazy, and I haven't documented why it works, but I have found that turning off filtering of bogons on the wireless interface, lan, and bridge to LAN fixes the DHCP weirdness with Apple Macs connecting to my Atheros cards under 2.2.2.

    Strictly speaking, neither the wireless interface nor the bridge need to be assigned any address.  I have also added a rule on the lan allowing UDP DHCP traffic to and from ports 67-68 from any source, and to any destination.  If you assign addresses to the wifi adapter and the bridge you must add the same DHCP pass rule to each interface, although it may just be required on the bridge due to the default bridge filtering rules in place when it is given an address.

  • LAYER 8 Netgate

    Why would you filter bogons on your own LAN network? is a bogon.

    12:11:44.380451 IP > UDP, length 300
    12:11:44.380873 IP > UDP, length 335

    Note the DHCP packet sourced from

    You took the default LAN interface configuration, changed it, and broke your network.

  • Whose brilliant idea was it to offer the option on the LAN interface page?

  • LAYER 8 Netgate

    pfSense can be used for a great many things.  There are plenty of ways to shoot yourself in the foot.  Doesn't mean the option shouldn't be there.  One person's OPT1 is another person's Multi-WAN, for example.