Pas d'accès internet sur ma pfsense



  • Bonjour à tous, je débute sur pfsense, j'espère donc ne pas vous sortir d'énormité en vous expliquant ma configuration. ( je suis sur VMware Workstation 10,  sur une Windows seven)

    Mon objectif est d'avoir une pfsense (contenant services : DHCP, proxy, IPS, routing )  avec trois interfaces :

    WAN : carte réseaux en bridged
    LAN : VMnet ( 10.0.0.1)
    DMZ : VMNET ( 10.10.0.1)

    La DMZ hebergera un serveur WEB ainsi qu'un VPN
    Le LAN herbergera un serveur WEB, Messagerie, stockage, base de donnée

    Mon problème est le suivant, ayant ma pfsense configurée, je me connecte a l'interface web via une Debian qui est sur le même segment d'ip que l'interface LAN ( Debian : 10.0.0.20)
    Ma debian ainsi que ma pfsense communiquent donc ( ping réussi )
    Lorsque je suis sur l'interface Web de ma pfsense, je souhaite donc installer squid3 ainsi que snort afin d'avoir le proxy et les IPS, cependant , ma pfsense n'arrive pas à communiquer avec le serveur de téléchargement des packages, en effet, lorsque je tente un ping google depuis le shell de ma pfsense, cela ne marche plus.
    *Et je dis plus, car j'observe qu'avant de configurer l'interface LAN, je pouvais ping google avec ma pfsense
    Je ne peux donc ni télécharger des packages, ni donner un accès internet à mes clients LAN …

    Je suis donc bloqué depuis 2 jours, à ne savoir comment résoudre mon problème, j'ai tenté plusieurs réinstallations, avec la version 2.1.5 et 2.2 de pfsense, ainsi que d'essayer en NAT et non en bridged pour l'interface WAN

    Je n'ai pas touché aux règles du firewall, j'indique comme DNS de mon interface WAN, celui même de ma connexion physique
    Je me retourne donc vers vous, ne sachant vraiment pas quoi faire d'autres, en éspérant avoir été clair
    Merci d'avance, Bonne journée/soirée à vous !



  • As-tu essayé:

    • un traceroute depuis pfSense
    • un coup d'oeil sur les log du firewall


  • ( je suis sur VMware Workstation 10,  sur une Windows seven)

    Vos problèmes viennent très probablement d'une mauvaise perception, ou gestion, des questions réseau liées à cet environnement virtualisé.
    Je ne peux que vous inciter à suivre les conseils donnés précédemment pour tenter d'y voir clair.

    je souhaite donc installer squid3 ainsi que snort afin d'avoir le proxy et les IPS

    Très mauvaise idée ! Ajouté à la virtualisation sur Windows Seven tout cela relève de l’hérésie la plus complète en matière de sécurité. Dans votre cas elle (la sécurité) risque de relever de l'illusion.
    Si vous avez un vrai besoin de sécurité rien de tout cela ne tient la route. Mais c'est vous le patron de cette galère.



  • Alors tout d'abord merci d'avoir pris le temps de me répondre !

    Chris4916:

    La traceroute depuis ma pfsense n'aboutit nul part, je me suis peut-être trompé de manip (#traceroute 8.8.8.8), c'est une première pour moi, voici ce que cela m'affiche :

    Ensuite, qu'entends tu par les "logs" de mon firewall ? J'imagine bien que je vais passer pour une chèvre en demandant ce genre de chose, mais je suis débutant et n'en suis pas un particulièrement doué en matière de réseau malheureusement

    Ccnet

    J'ai effectivement lu plusieurs personnes indiquant que la virtualisation pour une pfsense était loin d'être la solution idéale, cependant je dois mettre en place cette infrastructure dans l'optique de mon projet annuel ( je suis en seconde année d'informatique, à l'ESGI), je vais donc devoir faire une démonstration sur mon PC, et donc devoir faire tourner cette infrastructure sur ce même PC, je n'ai pas vraiment le choix ….




  • ça ne va pas bien loin effectivement  :o
    Que donne

    netstat -r
    

    [JOKE_MODE]
    on n'apprend pas ces trucs basiques à l'ESGI ?  :P
    [/JOKE_MODE]



  • Manifestement le trace route n’aboutit pas.
    Des pings de proche en proche semblent nécessaires.

    Pour les logs il n'est pas nécessaire d'avoir de nombreuses et abondantes connaissances réseau. Par contre lire la documentation est utile.
    Pour les logs : Status: System logs: Firewall C'est quand même un minimum de se renseigner sur la disponibilité des logs lorsque l'on travaille avec un nouveau produit.

    donc devoir faire tourner cette infrastructure sur ce même PC

    Essayez de bien dissocier les questions induites par cette architecture de démonstration de votre propos principal. Toutefois je ne comprend pas très bien où vous voulez en venir avec une architecte firewall proxy ids alors que vous ne connaissez pas la commande trace route. Étonnant !



  • Toutefois je ne comprend pas très bien où vous voulez en venir avec une architecte firewall proxy ids alors que vous ne connaissez pas la commande trace route. Étonnant !

    Notre sujet nous demande explicitement de mettre cela en place, bien qu'il doit y avoir deux élèves sur la classe entière sachant de quoi il en retourne, on préfère plutôt la programmation dans cette promo … , notre professeur de réseau en première année n'ayant certainement pas amelioré les choses ( même si c'est pas une excuse j'en suis conscient)

    Je joins donc au post les screens des logs du firewall ainsi que le résultat du "netstat -r" ( je m'excuse par avance pour le résultat tronqué, je ne peux agrandir l'écran de ma machine virtuelle pfSense, et je ne trouve pas comment remonter dans le shell)

    Ce que je ne comprends pas cependant, c'est que j'arrive à communiquer avec l'exterieur ( je ping 8.8.8.8 ainsi que www.google.fr avec succès ), et dès ma premiere connexion à l'interface web de ma pfsense, plus rien

    Merci encore pour votre temps

    ![netstaat -r.PNG_thumb](/public/imported_attachments/1/netstaat -r.PNG_thumb)
    ![netstaat -r.PNG](/public/imported_attachments/1/netstaat -r.PNG)





  • Houlà…. tu pars de loin, ça ne va pas être facile  :-\

    1 - pour n'afficher que les routes en IPV4

    netstat -4r
    

    2 - si tu le fais en SSH, tu devrais pouvoir remonter dans l'affichage non ?

    3 - pas étonnant que ça ne marche pas, il semble que ta route par défaut soit "pfsense"

    Fais l'effort de décrire un peu plus en détail ce que tu as configuré car le problème me semble être celui là. Pour faire simple, ta route par défaut devrait être l'adresse IP qui sur ton réseau, donne accès à internet.
    Si ta route par défaut est pfSense, alors demuis pfSense, tu va atteindre pfSense, soit, ce n'est pas surprenant, 127.0.0.1
    Du coup, comme c'est ce que tu obtiens avec le traceroute, ça marche plutôt pas mal non ?  :P



  • Houlà…. tu pars de loin, ça ne va pas être facile  :-\

    Comme tu dis ! Merci de pas avoir laché l'affaire en tout cas, ça me fait plaisir !

    si tu le fais en SSH, tu devrais pouvoir remonter dans l'affichage non ?

    Oui … l'idée ne m'est pas venue, désolé :-(

    Pour le reste effectivement, ça ne risquait pas de marcher ... après avoir fait un :

    #route del default

    puis

    #route add default 192.168.1.1

    J'ai effectivement récupéré ma connexion, je vais donc pouvoir installer mes packages, et essayer de configurer tout ça au mieux ;)

    Merci encore à vous deux pour votre temps et vos conseils, vous m'avez sortit d'un mauvais pas, et je ne risque pas de refaire la même boulette !!
    Excellente soirée à vous !



  • Bonjour à tous, je débute sur pfsense, j'espère donc ne pas vous sortir d'énormité en vous expliquant ma configuration.

    je desire crrée un portail captil avec Pfsense 2.2.6 sur une machine possédant une carte réséau (LAN) et une carte wifi (WAN)

    WAN : Ath0 est en DHCP
    LAN: Rl0 : 172.16.1.121/23

    je suis un tuto me disant de telecharger les packages squid et squidguard mais apres plusieurs tentatives j'ai constaté que j'ai pas accèes a internet  et je sais plus quoi faire .

    Je n'ai pas touché aux règles du firewall,

    Je me retourne donc vers vous, ne sachant vraiment pas quoi faire d'autres, en éspérant avoir été clair
    Merci d'avance, Bonne journée/soirée à vous !



  • c'est mieux de montrer l'image de ta config.
    tu as activé Ou donné les autorisation de quelle manière et si toi meme ou ta machine a eu cette autorisation par exepmle




  • @nikobou

    Bonjour,

    Merci de créer votre propre fil de discution svp.
    Et pour bien débuter  ;) https://forum.pfsense.org/index.php?topic=79600.0

    Cdt


Log in to reply