Problemas con mi red (migración de Debian a pfSense)



  • Espero porder explicarme lo mejor porsible, en mi red tengo unos servidores trabajando:

    • 1 proxy en debian con dos 2 interfaces: LAN(192.168.1.0/24)  WAN(ip entregado por el ISP)…  un server el dhcp... tengo dos servidores que ya vienen trabajando el servicio de DNS... hasta alli todo funciona perfectamente... como muestro en la imagen

    Quiero usar Pfsense en dos maquinas para quitar esas en debian... uno en donde trabaje el dhcp y el dns... y otro para que sea prozy/firewall... lo configure y funciona...... pero la red se convierte en una lentitud extrema... se queda esperando para abrir la paginas web....  no entiendo que ocurre... soy novato... supongo que debe ser algo en las rutas.. si alguien puede ayudarme se los agradeceria

    Luis



  • ¿Qué rangos tienes puestos en LAN/WAN de cada pfSense?

    ¿Cómo están configurados los DNS externos para cada pfSense?



  • originalmente en debian tengo configurados dos dns: 192.168.30.1 y 192.168.30.7 y con ellos funcionan perfectos… ahora en server pfsense que monte para que funcione como dhcp y dns... lo configue en el 192.168.30.5 y otro DNS en el 192.168.30.15.... todos son del mismo rango ip 192.168.30.0/24...

    ahora bien en el servidor pfsesne que puse como DNS solo tiene una sola interfaz... y lo toma como WAN... deshabilite el firewall que tiene por defecto encendido por que no me interesa que funcione en ese. En la primera imagen muestro el dashboard de este server....

    en la segunda imagen es el dashborad del que esta como proxy y salida principal.... no se que otra info pudieran necesitar para ayudarme?

    Luis





  • Rebel Alliance

    • La WAN del pfSense de la segunda imagen, está en "half-duplex".

    La "Forzaste" a ese modo, o tienes un "Duplex Mismatch" ?

    • Con los DNS estoy mareado  :P

    192.168.30.15 ? Es "otro" DNS presente en la red, y que no indicaste en el diagrama ?

    No sería mejor utilizar el primer pfSense como "DNS Forwarder"



  • A parte de lo que pregunta ptt

    Me llama la atención que el proxy sirve en LAN a 100 Mbit/s

    También me pregunto qué rapidez de resolución DNS están teniendo los clientes. Yo verificaría eso mediante nslookup.



  • Disculpen que no pude responderles ayer mismo, gracias por sus preguntas e inquietudes… para la interrogante de ptt:

    • Ayer justo antes de poner las imagenes levante otro DNS de prueba y es el 192.168.30.15 y me puse a probar con el, es otro DNS… que a fin de cuentas seria el secundario que dejaria dentro de mi LAN.

    • EL primario es 192.168.30.5 que a su vez tiene el servicio DHCP.

    • El Proxy (Squid / Dansguardian / Firewall) tiene la ip 192.168.30.97.

    De momentos mi amigo bellera el proxy esta trabajando a 100Mbit/s, el anterior proxy tambien laboraba a esa velocidad sin generar ningun problemas de rendimiento o desempeño en la red, pero se esta por adquirir pronto un sw con puertos 1000/100/10Mbit/s, pero esta en aprobracion de presupuesto, uds entienden como es eso.

    Con respecto al DNS… si estuve viendo las respuesta a travez de nslookup y dig, para conocer a fondo si estaban realizando respuestas adecuadas, como el ejemplo en la imagen siguiente.

    Les agradezco todo la ayuda o consejo que puedan darme.

    Luis




  • Si tienen otra inquietud para porporsionales la info, estoy en este aprieto y de verdad que pfsense me parece una herramienta fantastica, seguire revisando y viendo que puedo hacer, espero que puedan ayudarme mis amigos.

    Luis



  • Habra algun problema con los DNS que esas usando en el PFsense ? veo que el DNS local es la ultima opcion.

    La lentidud se presenta con proxy y sin el ?

    Saludos



  • Como estas acriollo!… te comento que los DNS que puse de primero son los del mi proveedor de servicios y he podido utilizarlos en otro sitio sin problema alguno.... pero puedo hace la prueba poniendo los mios de primero, gracias por esa idea....

    La lentitud se presenta cuando le asigno a todos mis equipos el proxy pfsense y activo los dns/dchp pfsense, si los apago y levanto en debian es como si nada hubiese ocurrido y todo vuelve a la normalidad.

    Creo que es importante que por el proxy pfsense tengo configurado una salida Metro Ethernet de 6Mb; por el proxy debian apenas tengo una salida ADSL de 2Mb, por ello tengo unas cuantas computadoras que estan configuradas con ip estatica y en el proxy del navegador tengo configurado el proxy pfsense y funciona.

    No entiendo que es lo que sucede... pense que podria ser problemas de rutas pero no le veo sentido, si pueden ayudarme se los agradeceria...

    Luis



  • Prueba a activar la casilla Resolv dns v4 first de la configuración general del proxy.

    Si eso no supone un cambio…

    Tendrías que hacer pruebas de tiempo de respuesta que no requieran resolución DNS y que sean otros accesos que navegación web. ping, tracert, ndt...

    https://forum.pfsense.org/index.php?topic=59501.msg323077#msg323077

    Además tengo entendido que DansGuardian es un filtro que requiere bastante máquina. Igual tienes un problema de optimización de DansGuardian.



  • Es muy bueno lo que comenta Bellera en relacion a la resolucion por IPV4.

    Y tambien coincido en que una mala config del dansguardian puede provocar problemas de este tipo, me paso alguna vez con un ClearOS, la maquina que tenia no aguantaba el caudal de solicitudes que recibia y abria muchisimas instancias de dansguardian para tratar de darles servicio. Lo que provocaba que la navegacion fuera lentisima.

    Prueba sin filtrado y coméntanos que pasa.

    Saludos


Log in to reply