SOLVED Ubuntu Server 12.04 and Pfsense 2.2



  • I have a ubuntu machine with its onboard network card (eth0) and an add-in one (eth1).
    I have set up bridged connection in VM, and im getting internet though pfsense (i can ping google.com)
    i can open the pfsense webgui on my computer
    I got my modem DHCP coming in though a powerline adapter into eth1, and my other computer connected to eth0
    Problem is, that even though both pfsense and my computer have internet connection, ubuntu is left out.
    Ubuntu is given the IP 192.168.0.2 and pfsense has 192.168.0.3, my desktop has 192.168.0.15
    I can connect to my apache2 webserver though http://192.168.0.2/ but internet connection is dead on ubuntu side.

    I think it has something to do with my /etc/network/inferfaces file…

    I have come so far, that if i restart networking (/etc/init.d/networking restart)
    i get this error:
    RTNETLINK answers: File exists
    Failed to bring up eth0:1
    ssh stop/waiting
    ssh start/running, process xxxxx
    ssh stop/waiting
    ssh start/running, process xxxxx



  • SOLVED!

    a simple "sudo dhclient eth0:1" solved it…


Log in to reply