Squid3 breaks port forwarding?



  • Hello,

    being new to pfSense (but not to networking in general) I am afraid I am asking a silly and very obvious question, but somehow installing the squid3 package seems to be breaking our port forwarding for port 25…

    I checked the forum and FAQs but unfortunately could not find anything that matched my search criteria...


    We have set up a new pfSense machine and configured WAN/LAN and can confirm general connectivity.

    Since we want to use pfSense to publish our Exchange-Server our first step was setting up a port forward for SMTP (Firewall: NAT: Port Forward) which also created a linked firewall rule; everything worked as expected and the inbound connection on the WAN-address port 25 was forwarded to our internal Exchange. :)

    Next we installed the squid3 package to be able to publish OWA, OutlookAnywhere, etc. and the port forward stops working… as soon as we remove squid3 everything goes back to normal.

    We then tried logging to try and diagnose the problem, but no log entries appeared although the SMTP connection wasn't working (with squid3 installed); after uninstalling squid3 the success log entries appeared...

    I had expected to be able to use port forwarding and squid3 together... does anyone know what are we missing here?

    Thanks,
    Karl


Log in to reply