Squid3, strange redirect from 80 to 443



  • Hello,

    Just installed Squid3. I want tu publish my webserver on DMZ, over port 80.

    So i created rules in squid3 from my wan-adress to my webserver on dmz.

    I created firewall rule to allow port 80 to wan address.

    BUT, no response. In the log i can se "Destination" is "my-wan-ip:443" and not "my-wan-ip:80"

    Why is this? It´s a fresh install of pfSense 2.2.1



  • Hmm I get the same problem on another 2.2.2 -installation :/



  • This will explain the error I get on email, when I open an email with web contenent it goes to port 443 instead of port 80.
    Is your Squid set as transparent ? ( as mine was when this problem start).
    thanks



  • Hello,

    I use it as a reverse Proxy to publish my website. Not as a typical surf-Proxy.



  • Do you have a captive portal enabled?

    See my post at https://forum.pfsense.org/index.php?topic=87280.0



  • Hello, no I dont use captive portal. I Think this is related to the newer FreeBSD base operating system on 2.2, that it cannot listen on low ports. I get same error in HAproxy. I have disabled WebGUI redirect.

    I will try to do a forwarding rule from port 80 to a higher port i firewall rules settings


Log in to reply