Streaming Error with squidclamav one some special sites



  • Hi folks,

    I'm using squid + the integrated squid clamav which works most of the time perfectly.
    But if I try to stream some music from my favorite radio station it is not working.
    If I deactivate av scanning working.

    I found out that the stream is using files with the extension aac or m3u.

    Here is my abortcontent config from squidclamav.conf

    Do not scan audio streaming

    abort ^.*.(m3u|pls|wmx|aac|mpeg)$
    abortcontent ^audio/m3u$
    abortcontent ^audio/pls$
    abortcontent ^audio/wmx$
    abortcontent ^audio/mpeg$
    abortcontent ^audio/aac$
    abortcontent ^.audio/mp4.$

    Is anyone having a clue?

    Thanx.



  • Hi webstor,

    I've literally just discovered the same issue. Deactivate squid AV scanning and streaming works instantly. Turn squid av scanning back on and no more radio streaming through TuneIn Radio on my phone.

    I'm definitely a squid newbie so any assistance from the pros would be really appreciated :)



  • Hi,

    I ran into the same issue. Using Squid3.

    Noticed that in my case the streaming would start after 3-5 min. Also check Services/Proxy Server/Real Time and noticed quite a few TCP_MISS_ABORTED. My interpretation was that these occurred due to the client application in my local network timed out trying to connect to the remote server.

    Tried adding below in squidclamav.conf rendered no positive result:

    # Do not scan audio streaming
    abort ^.*\.(m3u|pls|wmx|aac|mpeg)$
    abortcontent ^audio/m3u$
    abortcontent ^audio/pls$
    abortcontent ^audio/wmx$
    abortcontent ^audio/mpeg$
    abortcontent ^audio/aac$
    abortcontent ^.*audio\/mp4.*$
    

    In my case the resolution was below parameter change in squidclamav.conf:

    dnslookup 0
    

    After restarting squid and c-icap services, audio streaming worked as expected.

    //Jimmy


Log in to reply