PIA & OpenVPN breaks internet



  • I have followed this guide
    https://forum.pfsense.org/index.php?topic=76015.0

    I have used it before and everything worked correct. The only thing I have changed was adding a DMZ to the mix and attempting to set it to only use the VPN on the DMZ interface.

    I current network setup is

    Wan-Internet

    Lan-This is my main interface for network traffic.

    DMZ-I created this DMZ interface for my PS4 only. I didn't want to open up ports and I wanted to separate the Ps4 from my network.

    VPN-For the PS4 so I can connect to different countries for Netflix and other reasons.

    I am pretty sure it has something to do with my rules. If I disable the VPN interface my internet works again.

    I am going to upload a few pictures. If any other information is needed I will gladly supply.

    Thanks



  • Look at your manual outbound NAT - You have two identical subnets handled differently.

    The first one to be encountered is the only one that will work.  Thats  PIA.  192.168.2.0/24

    You need to rethink your handling of this.


  • LAYER 8 Netgate

    The NAT is only in effect when the traffic is being routed out that interface.  That's the standard method of NAT when Multi-WAN.

    This is probably the PIA pushed default route AGAIN.

    Check the Don't pull routes checkbox in your PIA client config.  It will then be up to you to policy route traffic to PIA.

    I have no idea what that rule is on your PIA interface.  Delete it.

    You need to policy route traffic by matching it on the interface it is RECEIVED ON (DMZ, whatever the 192.168.2.0/24 interface is) and set the GATEWAY to PIA for that traffic.  Read the tutorial again.

    https://doc.pfsense.org/index.php/What_is_policy_routing


Log in to reply