Captive Portal Status button does not display



  • The Captive Portal status should show up once the captive portal is enabled but it does not show?
    I can go to: https://FIREWALLIP/status_captiveportal.php
    and that displays the status page, but the button itself is missing?


  • Banned

    What button where? Post a screenshot.



  • A button is missing, ok.
    What button ? Why omitting the details ?

    Possible that you show us what you think that is missing ?

    Btw; if there is only ONE zone, there is NO list to select between zones.




  • The status button is missing alltogether.
    See 2 screenshots below, one of a brand new install and one of an older install which has been updated over time.
    Captive portal is enabled on both installs

    ![Brand new install.jpg](/public/imported_attachments/1/Brand new install.jpg)
    ![Brand new install.jpg_thumb](/public/imported_attachments/1/Brand new install.jpg_thumb)
    ![older and upgraded install.jpg](/public/imported_attachments/1/older and upgraded install.jpg)
    ![older and upgraded install.jpg_thumb](/public/imported_attachments/1/older and upgraded install.jpg_thumb)



  • I haver taken another pic showing that captive portal is enabled but the button for the status is missing

    ![Missing button.jpg](/public/imported_attachments/1/Missing button.jpg)
    ![Missing button.jpg_thumb](/public/imported_attachments/1/Missing button.jpg_thumb)


  • Banned

    Uh. Menu item is not a button. Beyond that, cannot reproduce. What theme are you using?



  • Sorry OK the menu item is missing.



  • I found 3 possibilities why the Captive Status Menu doesn't show up.

    First: (/etc/inc/fbegin.inc - line 172) : If there are NO captive portal(s) defined in the $config, there is no Status menu Second : maybe you have forbidden the view of this page (check login user - and his rights)
    Third  : Test this first: use another browser ! (or: flush you browser cache).



  • Hi,
    thanks for the suggestions,
    I checked (etc/inc/fbegin.inc) but no such file exists?
    I also checked the security settings and the user is set to have access to everything
    I the flushed the browser and used a different browser as well but still no luck.

    I tried to delete the captive portal and recreate it, and rebooted the firewall, but have the same results.

    I am running version 2.1.5 so it is not the very latest one if this makes a difference?

    ![File Structure.JPG](/public/imported_attachments/1/File Structure.JPG)
    ![File Structure.JPG_thumb](/public/imported_attachments/1/File Structure.JPG_thumb)


  • Banned

    @swalz:

    I checked (etc/inc/fbegin.inc) but no such file exists?

    It's **/**etc/inc/fbegin.inc. You need absolute path, not relative.

    Regardless, try with admin, not some random account.



  • Hi,
    Sorry I am not a linux expert and might have written it wrong.
    I checked (/etc/inc/fbegin.inc) and there is no such file.
    I have attached 2 screenshots one from WINSCP and one from the command line
    I am also using the admin user, I have no other users setup.



    ![Command line List directory.jpg](/public/imported_attachments/1/Command line List directory.jpg)
    ![Command line List directory.jpg_thumb](/public/imported_attachments/1/Command line List directory.jpg_thumb)


  • Banned

    The file is actually in /usr/local/www, not in /etc/inc. Regardless, I would suggest to reinstall your box.



  • @swalz:

    Hi,
    Sorry I am not a linux expert and might have written it wrong.
    I checked (/etc/inc/fbegin.inc) and there is no such file.
    I have attached 2 screenshots one from WINSCP and one from the command line
    I am also using the admin user, I have no other users setup.

    Be careful : 'we' always presume that you use the SAME version as we do.
    Version "2.1.5" is way back and you shouldn't hold that information back. Ours answers will be terrible wrong. With "2.1.5" support is simpler: upgrade, because 'we' (most of us, I guess) do not remember how things were done years ago ….
    So, it's logic that you didn't find the file /etc/inc/fbegin.inc  (I mentioned this file so you can see how things are handled).

    As said: reinstall, and please, forget about Windows 98 .... sorry, pfSense 2.1.5  ;)



  • Sorry I should have added that info straight from the start.
    I have tried to upgrade and also newly install a 2.2 version, My problem is that I have an IPSec tunnel routing all traffic through the tunnel and the captive portal does not work if you have a tunnel as the interface is not reachable, therefore the captive portal page does not display.
    Going from one issue into another.



  • 2.2 or 2.2.1 ?

    IPSEC was an issue before, or is it new ?

    Captive portal is running on an dedicated (physical) interface like OPT1 (that you are routing through IPSEC) or the entire LAN is being put through IPSEC ?

    I never tried such a setup, but I guess that if an interface is listed, in this case, the IPSEC interface, when creating a captive portal zone, it should work - everything else is a question of setting it up. When creating an interface, the default firewall rule block everything. What are your rules ?

    edit: ah, more info is here : https://forum.pfsense.org/index.php?topic=91076.0



  • Hi,
    I have tried this on 2.2.1
    I have an IPSec tunnel routing all traffic through the tunnel.
    This is working on 2.1 as there is a setkey rule to allow traffic going to the interface. But I cannot add this rule in 2.2.1 as Strongswan is not ready and not well developed to be used in such a firewall. There is next to no documentation about strongswan either.
    I can have the Captive Portal on the LAN or OPT1, on 2.1.5 it works both due to the setkey rule. ( both interfaces have all traffic routed through the IPSec tunnel)
    But on 2.2.1 this does not work as I cannot set these rules, therefore all traffic (including traffic addressed to the interface) are going through the IPSec tunnel and therefore the captive portal does not display or open.
    Bam no traffic possible.
    My firewall rules are set to allow anything from anywhere to anywhere any ports. (basically open for everything just to see if I can get the captive portal working)

    The IPSec tunnel is active before the Captive portal is created but when selecting an interface you can only Choose WAN, LAN, OPT1 and not the actual tunnel.

    Frustrating  :-\



  • Just an idea: what about 'pointing' the gateway of OPT1 (your captive portal interface) to the IPSEC interface ?



  • IPsec is not really an interface, it is a VPN tunnel.
    The gateway in DHCP is the OPT1 interface. Everything after this is already routed into the tunnel, so there is nothing else I could use as Gateway.


Log in to reply