Pfsense 2.2.1 - Squidguard - не запускается



  • Установил с нуля pfsense 2.2.1 x64, squidGuard ни в какую не стартует.
    Пробовал комбинации:
    squid 2.7.9 pkg v.4.3.4
    squidGuard-devel 1.5_1beta pkg v.1.5.6

    squid3 beta 3.4.10_2 pkg 0.2.6
    squidGuard-devel 1.5_1beta pkg v.1.5.6



  • @Angel_19:

    Установил с нуля pfsense 2.2.1 x64, squidGuard ни в какую не стартует.
    Пробовал комбинации:
    squid 2.7.9 pkg v.4.3.4
    squidGuard-devel 1.5_1beta pkg v.1.5.6

    squid3 beta 3.4.10_2 pkg 0.2.6
    squidGuard-devel 1.5_1beta pkg v.1.5.6

    А squid 3.2, 3.3 не присутствует в пакетах ? И squidGuard по-старее ?



  • А squid 3.2, 3.3 не присутствует в пакетах ?

    Нет.

    И squidGuard по-старее ?

    Есть, попробую его.




  • Попробовал:

    squidGuard 1.4_7 pkg v.1.9.10
    squid 2.7.9 pkg v.4.3.6

    squidGuard 1.4_7 pkg v.1.9.10
    squid3 3.4.10_2 pkg 0.2.6

    squidGuard - не стартует.



  • @Angel_19:

    squidGuard 1.4_7 pkg v.1.9.10
    squid3 3.4.10_2 pkg 0.2.6

    у меня работает стабильно, но на х86.
    А что в логах пишет?



  • у меня работает стабильно, но на х86.
    А что в логах пишет?

    Чистая установка или обновляли?

    Я пробовал и x86 - проблема сохраняется.

    В логах ничего криминального вроде нет:

    24.03.2015 06:00:34 : [sg_reconfigure_user_db]  Begin with '/var/db/squidGuard'
    24.03.2015 06:00:34 : [sg_reconfigure_user_db] Warning User destinations list empty.
    24.03.2015 06:00:34 : [sg_create_config]  Add rewrites:  safesearch;
    24.03.2015 06:00:34 : [sg_create_config]  Add Default
    24.03.2015 06:00:34 : [sg_redirector_base_url]  Select redirector base url (http://192.168.10.2:80/sgerror.php?url=403 &a=%a&n=%n&i=%i&s=%s&t=%t&u=%u)
    24.03.2015 06:00:34 : [sg_reconfigure]  Save squidGuard config to '/usr/pbi/squidguard-amd64/etc/squidGuard/squidGuard.conf'.
    24.03.2015 06:00:34 : [squid_reconfigure]  Remove old redirector options from Squid config.
    24.03.2015 06:00:34 : [squid_reconfigure]  Add new redirector options to Squid config.



  • Доступные пакеты squid и squidGuard сегодня также изменились: см. приложенный скриншот.




  • В пакетах пропал сквид с поддержкой ssl ??????



  • Скрин с пакетами это на х86 или х64 ?



  • Вчера обновил 2.2 до 2.2.1. После обновления squidguard упал и при попытке перезапуска ругался на отсутствующие директории, права доступа к ним и какую-то библиотеку (к сожалению не сохранил логи). Помогла переустановка squidguard (не удаление и установка, а просто переустановка). После переустановки заново загрузил Blacklist. После это squidguard нормально запустился и при ребуте системы тоже стартует без ошибок.



  • @flagman:

    В пакетах пропал сквид с поддержкой ssl ??????

    так может он у него установлен, а здесь скриншот вкладки доступных пакетов



  • Скрин с пакетами это на х86 или х64 ?

    x64



  • Не нужна Вам 2-ая версия сквида. Ищите 3-ю (жел-но beta). Не заработает на x64 - пробуйте х32.

    Сделайте так.
    Сохраните бэкап конфига пф БЕЗ (!!!) пакетов. Разверните новый пф , подгрузите этот конфиг, затем ставьте сквид 3-ий (не 2-ой!!!),
    проверяйте его работоспособность, сохраняйте бэкап этого конфига и только после этого ставьте последний сквидгвард.



  • Такая же была ситуация Squidguard не хотел запускаться (.
    Как только добавил хоть одно условие, например, добавил категорию в Target Categories и назначил ее в Common ACL и после SAVE все запустилось.



  • @saTSGM:

    Такая же была ситуация Squidguard не хотел запускаться (.
    Как только добавил хоть одно условие, например, добавил категорию в Target Categories и назначил ее в Common ACL и после SAVE все запустилось.

    Спасибо! Помогает! Только один глюк все равно остается: когда нажимаешь Apply (SquidGuard: General settings), то тут же на странице показывает, что он остановлен (SquidGuard service state: STOPPED), но если просто обновить эту страницу или смотреть статус сервиса (Status: Services), то показывает что SquidGuard работает.



  • (Status: Services), то показывает что SquidGuard работает.

    Не у меня такого не было, а Вы какой браузер используете? Я Google Chrome, в нем при нажатии кнопки Apply, если служба стартанула, то это сразу видно на странице SquidGuard: General settings.
    А если после Status: Services - вернуться обратно SquidGuard: General settings будет показывать что работает?



  • @MrIgor:

    Вчера обновил 2.2 до 2.2.1. После обновления squidguard упал и при попытке перезапуска ругался на отсутствующие директории, права доступа к ним и какую-то библиотеку (к сожалению не сохранил логи). Помогла переустановка squidguard (не удаление и установка, а просто переустановка). После переустановки заново загрузил Blacklist. После это squidguard нормально запустился и при ребуте системы тоже стартует без ошибок.

    Тоже не сохранились логи, к сожалению.
    pfSense v 2.2.1; x86
    SQUID версии 2.7. (Боязно ставить бету).
    squidGuard тоже последней стабильной версии (на данный момент удалил, посему версию сказать не могу).

    Проблема в общем следующая: squidGuard не стартует, при попытке запустить его принудительно, в services, имеем два варианта развития событий.
    1. СквидГвард успешно запускается, и успешно работает некоторое количество времени.
    2. СквидГвард падает, и останавливает Сквид.

    При втором варианте поднять сквидГуард (и Сквид) возможно только после полной переустановке Гуарда и блэклиста).

    На данный момент Сквид решил запуститься лишь после полного удаления сквидГуарда.

    Я заметил, что не у меня одного такие проблемы. Поделитесь опытом, как их предотвратить.

    П.С. Пфсенс стоит на ВМваре. На данный момент установлены два пакета. - Сквид и Опен-Вмваре.



  • @saTSGM:

    (Status: Services), то показывает что SquidGuard работает.

    Не у меня такого не было, а Вы какой браузер используете? Я Google Chrome, в нем при нажатии кнопки Apply, если служба стартанула, то это сразу видно на странице SquidGuard: General settings.

    Также использую Chrome.

    А если после Status: Services - вернуться обратно SquidGuard: General settings будет показывать что работает?

    Да.



  • @sudpmr:

    pfSense v 2.2.1; x86
    SQUID версии 2.7. (Боязно ставить бету).
    squidGuard тоже последней стабильной версии (на данный момент удалил, посему версию сказать не могу).

    Проблема в общем следующая: squidGuard не стартует, при попытке запустить его принудительно, в services, имеем два варианта развития событий.
    1. СквидГвард успешно запускается, и успешно работает некоторое количество времени.
    2. СквидГвард падает, и останавливает Сквид.

    Не устанавливайте squidGuard старый. Он тянет с собой еще и Сквид. Т.е. получается у вас 2 сквида.
    Удаляйте Сквид, СквидГвард и проверяйте руками из ком. строки наличие еще одного Сквида. Если есть - удаляйте его из ком. строки.

    Затем уст.  3-ий сквид и последний сквидгвард. Не пугайтесь, что они из нестабильных веток.


Log in to reply